Bug 1310383 - Selinux is blocking ovsdb-server
Selinux is blocking ovsdb-server
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-selinux (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ga
: 8.0 (Liberty)
Assigned To: Ryan Hallisey
Leonid Natapov
: AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-21 02:13 EST by Arie Bregman
Modified: 2016-04-07 17:29 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-selinux-0.6.54-1.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, SELinux blocked ovsdb-server from running, resulting in simple networking operations to fail. With this update, Open vSwitch is allowed to connect to its own port. As a result, ovsdb-server now runs without issues and the networking operations are completed successfully.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:29:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arie Bregman 2016-02-21 02:13:58 EST
Description of problem:
Selinux is blocking ovsdb-server, which causing to simple networking operations to fail.

Version-Release number of selected component (if applicable):
libselinux-2.2.2-6.el7.x86_64
selinux-policy-targeted-3.13.1-60.el7.noarch
libselinux-python-2.2.2-6.el7.x86_64
libselinux-utils-2.2.2-6.el7.x86_64

Steps to Reproduce:
1. Install rhos 7 using packstack

Actual results:
networking operations fail

Expected results:
networking operations run successfully

Additional info:
Logs provided.
Comment 3 Ryan Hallisey 2016-02-22 07:53:14 EST
Just make sure you generated these AVCs in permissive otherwise this might not solve the issue.
Comment 7 Leonid Natapov 2016-03-08 03:55:45 EST
openstack-selinux-0.6.55-1.el7ost.noarch

Basic network operations succeeded.
Comment 8 errata-xmlrpc 2016-04-07 17:29:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.