Bug 131039 - on upgrade from rh9 to fc2 up2date doesn't recognise version and architecture
on upgrade from rh9 to fc2 up2date doesn't recognise version and architecture
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-26 16:23 EDT by Tom
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 17:29:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom 2004-08-26 16:23:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
When using up2date and registering the system, the last screen shows
that the version and architecture of the system are corrupted
(according to this information my system version and architecture is '2').

As a result, I am not assigned a channel to get updates. Trying to
obtain one is only possible by entering a support code (wich I do not
have) or by buying an enterprise license.

I do assume I am normally allowed to gain access to the base channel
with one system.

I have tried deleting the profile in rhn, deleting the system profile
on my machine and creating a new one to no avail. Also I tried
rhn_check but nothing changed.

What options do I have but totally reinstall the system?  

Version-Release number of selected component (if applicable):
up2date-4.3.19-1

How reproducible:
Always

Steps to Reproduce:
1. run up2date as root
2. get 'system may not be updated untill it is associated with a channel'

or

1. run rhn_register
2. Get up to step 3, and notice the 'Red hat linux version: 2'
3. After sending package information to red hat, get the 'Cannot
update because channel is not assigned' error.

Up2date will not work. 

Expected Results:  System update

Additional info:
Comment 1 Adrian Likins 2004-08-26 17:29:32 EDT
No Fedora channels in RHN, so NOTABUG.

up2ate should work with fedora without 
registration being required.

Note You need to log in before you can comment on or make changes to this bug.