Bug 131039 - on upgrade from rh9 to fc2 up2date doesn't recognise version and architecture
Summary: on upgrade from rh9 to fc2 up2date doesn't recognise version and architecture
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date
Version: 2
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-26 20:23 UTC by Tom
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-08-26 21:29:32 UTC


Attachments (Terms of Use)

Description Tom 2004-08-26 20:23:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
When using up2date and registering the system, the last screen shows
that the version and architecture of the system are corrupted
(according to this information my system version and architecture is '2').

As a result, I am not assigned a channel to get updates. Trying to
obtain one is only possible by entering a support code (wich I do not
have) or by buying an enterprise license.

I do assume I am normally allowed to gain access to the base channel
with one system.

I have tried deleting the profile in rhn, deleting the system profile
on my machine and creating a new one to no avail. Also I tried
rhn_check but nothing changed.

What options do I have but totally reinstall the system?  

Version-Release number of selected component (if applicable):
up2date-4.3.19-1

How reproducible:
Always

Steps to Reproduce:
1. run up2date as root
2. get 'system may not be updated untill it is associated with a channel'

or

1. run rhn_register
2. Get up to step 3, and notice the 'Red hat linux version: 2'
3. After sending package information to red hat, get the 'Cannot
update because channel is not assigned' error.

Up2date will not work. 

Expected Results:  System update

Additional info:

Comment 1 Adrian Likins 2004-08-26 21:29:32 UTC
No Fedora channels in RHN, so NOTABUG.

up2ate should work with fedora without 
registration being required.


Note You need to log in before you can comment on or make changes to this bug.