Bug 1310390 - Restore snapshot with only subset of vm's disks will stuck the vm in image locked state
Restore snapshot with only subset of vm's disks will stuck the vm in image lo...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.3.1
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.4
: 3.6.4
Assigned To: Daniel Erez
Aharon Canan
: Automation, Regression
Depends On:
Blocks: 1317258
  Show dependency treegraph
 
Reported: 2016-02-21 04:50 EST by Raz Tamir
Modified: 2016-04-05 09:54 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-05 09:54:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
rule-engine: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)
engine and vdsm logs (1.40 MB, application/x-gzip)
2016-02-21 04:50 EST, Raz Tamir
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53877 master MERGED core: Remove condition for AsyncTaskType.notSupported. 2016-02-23 06:34 EST
oVirt gerrit 53887 ovirt-engine-3.6 MERGED core: Remove condition for AsyncTaskType.notSupported. 2016-02-23 07:22 EST
oVirt gerrit 54015 master MERGED core: CommandBase - avoid setting end status prematurely 2016-03-07 03:09 EST
oVirt gerrit 54017 master MERGED Revert "core: Remove condition for AsyncTaskType.notSupported." 2016-02-25 08:34 EST
oVirt gerrit 54019 ovirt-engine-3.6 ABANDONED Revert "core: Remove condition for AsyncTaskType.notSupported." 2016-02-25 08:37 EST
oVirt gerrit 54020 ovirt-engine-3.6 MERGED Revert "core: Remove condition for AsyncTaskType.notSupported." 2016-02-25 09:56 EST
oVirt gerrit 54393 ovirt-engine-3.6 MERGED core: CommandBase - avoid setting end status prematurely 2016-03-07 07:56 EST
oVirt gerrit 54433 ovirt-engine-3.6.4 MERGED core: CommandBase - avoid setting end status prematurely 2016-03-07 10:37 EST

  None (edit)
Description Raz Tamir 2016-02-21 04:50:54 EST
Created attachment 1128943 [details]
engine and vdsm logs

Description of problem:
After restoring a previewed snapshot that contain only subset ov the vm's disks, the vm state will stuck in 'image locked'.
Setup:
VM + 1 disk
Create a snapshot and after, create a new disk.
After the second disk s created, create second snapshot.
Preview the first snapshot and choose the option:
"Include in the previewed VM only the disks that are included in the snapshot."

Restore the previewed snapshot and wait for the vm state to change to 'image locked'.

Version-Release number of selected component (if applicable):
rhevm-3.6.3-0.1.el6.noarch
vdsm-4.17.21-0.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create vm + 1 disk
2. Create snapshot from the vm
3. Create second disk + second snapshot containing both disks
4. preview the first snapshot (step 2) and choose the option to "previewed VM only the disks that are included in the snapshot"
5. commit

Actual results:
The vm state will stuck on 'image locked'

Expected results:


Additional info:
Comment 1 Allon Mureinik 2016-02-21 06:36:36 EST
Daniel, can you please take a look at this ASAP?
Comment 2 Red Hat Bugzilla Rules Engine 2016-02-21 06:36:42 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Daniel Erez 2016-02-21 09:06:37 EST
Hi Raz,

The issue doesn't seem to reproduce on my local env (latest build). In which build did you reproduce it? Can you please attach a screencast with the exact steps (just in case I didn't follow it accurately).

Thanks!
Comment 4 Raz Tamir 2016-02-22 08:09:42 EST
Hi Daniel,
I use rhevm-3.6.3-0.1.el6.noarch on my environment.
1) Create vm
2) Add disk to vm
3) create snapshot
4) Add disk to vm
5) create snapshot
6) Preview the first snapshot (step 2) and choose the option to "previewed VM only the disks that are included in the snapshot"
7) Commit
Comment 5 Elad 2016-03-17 04:42:47 EDT
Commit snapshot gets completed successfully after the following:
1. Create vm + 1 disk
2. Create snapshot from the vm
3. Create second disk + second snapshot containing both disks
4. preview the first snapshot (step 2) and choose the option to "previewed VM only the disks that are included in the snapshot"
5. commit

VM and its attached images get unlocked once commit snapshot is finished.

Used:
rhevm-3.6.4-0.1.el6.noarch
vdsm-4.17.23.1-0.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.