Bug 13104 - logging out from gnome takes forever
logging out from gnome takes forever
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-27 07:54 EDT by gerald
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-19 15:28:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gerald 2000-06-27 07:54:42 EDT
If I click the logout button in gnome the "fading feature" will take forever 
and I can watch every individual pixel getting dark on my screen. I'll have 
to wait almost one minute until the logout confirmation pops up.

This special effect makes no sense on an unaccelerated server (framebuffer
in my case).
Comment 1 Owen Taylor 2000-07-19 15:33:29 EDT
Can you give some more details of your X configuration?

Is this using the 4.0.x or 3.3.6 server?
What CPU?
What resolution?
What video card?

It is hard for me to imagine taking the effect taking a minute to run even
with no hardware acceleration at all. 
Comment 2 Gerald Teschl 2000-08-02 07:12:46 EDT
I just checked it again under beta5: It takes precisely 47 seconds.
XF 4.0.1 FB server (from 4.0)
CPU=PII 300
VGA=791 (1024x768 @ 16bpp)
Lynx SMI 910 chip
Comment 3 Owen Taylor 2000-08-03 11:03:46 EDT
Here's a workaround - in /etc/X11/XF86Config-4, in the Driver
section, add the line:

 Option "ShadowFB" "off"

It turns out that the problem is a bad interaction between the 
frame-buffer shadow code and the way I do the iris effect.
Comment 4 Dale Lovelace 2000-08-19 15:28:15 EDT
Are we planning to make this automatic? Should this bug move to Xconfigurator?
Comment 5 Owen Taylor 2000-08-19 15:50:31 EDT
Sorry - I've already worked around the problem a couple of weeks
ago in gnome-core, by doing the logout animation in a different
way but forgot to close the bug.

Note You need to log in before you can comment on or make changes to this bug.