Bug 1310406 - Dnf downloads the package but than says it doesn't exist
Dnf downloads the package but than says it doesn't exist
Status: CLOSED DUPLICATE of bug 1257965
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-21 06:49 EST by Ondrej Svetlik
Modified: 2016-02-29 07:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 07:17:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Svetlik 2016-02-21 06:49:22 EST
Description of problem:
We (at FlexiBee) have our own RPM repository. It works fine with yum, but dnf fails to upgrade our package.

Version-Release number of selected component (if applicable):
$ dnf --version
1.1.6
  Nainstalováno: dnf-0:1.1.6-2.fc22.noarch na 2016-02-17 19:10
  Sestaveno    : Fedora Project na 2016-02-03 12:22

  Nainstalováno: rpm-0:4.12.0.1-14.fc22.x86_64 na 2015-12-20 20:34
  Sestaveno    : Fedora Project na 2015-11-20 13:22


How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh http://download.flexibee.eu.s3-website.eu-central-1.amazonaws.com/download/2016.1/2016.1.8/flexibee-client-2016.1.8-1.noarch.rpm
2. dnf upgrade flexibee-client

Actual results:
# rpm -q flexibee-client
flexibee-client-2016.1.8-1.noarch
# dnf upgrade flexibee-client
Last metadata expiration check performed 0:04:16 ago on Sun Feb 21 12:28:39 2016.
Závislosti vyřešeny.
================================================================================
 Package                Arch          Verze               Repozitář        Vel.
================================================================================
Aktualizace:
 flexibee-client        noarch        2016.1.9-1          flexibee        115 M

Shrnutí transakce
================================================================================
Aktualizace  1 Package

Celková velikost ke stahování: 115 M
V pořádku [a/N]: y
Stahování balíčků:
flexibee-client-2016.1.9-1.noarch.rpm           1.1 MB/s | 115 MB     01:41    
--------------------------------------------------------------------------------
Celkem                                          1.1 MB/s | 115 MB     01:41     
Spouštím kontrolu transakce
[Errno 2] Adresář nebo soubor neexistuje: u'http://download.flexibee.eu/download/rpm-repository/default/RPMS/flexibee-client-2016.1.9-1.noarch.rpm'
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
# file /var/cache/dnf/flexibee-933c35cd256edfab/packages/flexibee-client-2016.1.9-1.noarch.rpm 
/var/cache/dnf/flexibee-933c35cd256edfab/packages/flexibee-client-2016.1.9-1.noarch.rpm: RPM v3.0 bin i386/x86_64 flexibee-client-2016.1.9-1
# rpm -Uvh /var/cache/dnf/flexibee-933c35cd256edfab/packages/flexibee-client-2016.1.9-1.noarch.rpm 
Připravuji...                        ################################# [100%]
Updating / installing...
   1:flexibee-client-2016.1.9-1       ################################# [ 50%]
Cleaning up / removing...
   2:flexibee-client-2016.1.8-1       ################################# [100%]


Expected results:
Dnf should upgrade the package.

Additional info:
Same result with LANG=C

Running transaction check
[Errno 2] No such file or directory: u'http://download.flexibee.eu/download/rpm-repository/default/RPMS/flexibee-client-2016.1.9-1.noarch.rpm'
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Comment 1 Michal Luscon 2016-02-29 07:17:00 EST

*** This bug has been marked as a duplicate of bug 1257965 ***

Note You need to log in before you can comment on or make changes to this bug.