Bug 131041 - lesspipe.sh doesn't work with normal (non-compressed etc. ) files
lesspipe.sh doesn't work with normal (non-compressed etc. ) files
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: less (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-26 16:49 EDT by Gary Gatling
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 18:25:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Gatling 2004-08-26 16:49:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
/usr/bin/lesspipe.sh seems to be broken.
Running lesspipe on a normal file (that isn't compressed, or an
manfile  etc) fails.



Version-Release number of selected component (if applicable):
less-378-11

How reproducible:
Always

Steps to Reproduce:
1./usr/bin/lesspipe.sh foo
2.
3.
    

Actual Results:  command exits doing nothing on uncompressed file.

Expected Results:  Should have been piped to the pager.

Additional info:

This seems to be the same bug as 88614 which was CLOSED CURRENTRELEASE
with Red Hat 9.
Comment 1 Karsten Hopp 2004-08-26 18:25:18 EDT
lesspipe.sh is a helper script which should only be called by less. 
You should never run it directly. Instead set the environment 
variable 
LESSOPEN to '|/usr/bin/lesspipe.sh %s', p.e. with the following 
command: 
export LESSOPEN='|/usr/bin/lesspipe.sh %s' 
Our default configuration already does this for you. 
 
running 'less foo' then should do the right thing, i.e. uncompress  
files, or pipe them through man, ... 
 
 

Note You need to log in before you can comment on or make changes to this bug.