Bug 1310416 - Resume from Hibernated System not working on Fedora Workstation 22 RC due to missing Grub Parameter
Resume from Hibernated System not working on Fedora Workstation 22 RC due to ...
Status: CLOSED DUPLICATE of bug 1224151
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-21 07:24 EST by Anton S
Modified: 2016-02-22 13:05 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1224151
Environment:
Last Closed: 2016-02-22 13:05:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton S 2016-02-21 07:24:58 EST
+++ This bug was initially created as a clone of Bug #1224151 +++

Description of problem:
On Fedora Workstation 22 x86_64 RC1 (possibly on RC2 and RC3 as well), hibernation using "systemctl hibernate" works out of the box, however resuming from hibernated image not happening. The system warm boots instead and starts fresh session after running fsck.

Version-Release number of selected component (if applicable):
2.02 beta2

How reproducible:
By hibernating the system using standard systemd commands.

Steps to Reproduce:
1. Hibernate the system
2. Reboot into Fedora again

Actual results:
System boots into a new session after running fsck on all filesystems

Expected results:
System resumes the previous hibernated user session.

Additional info:
Adding resume=UUID=<UUID> parameter in GRUB_CMDLINE_LINUX variable inside /etc/default/grub and doing grub2-mkconfig -o /boot/grub2/grub.cfg resolves the issue. Try to regenerate initrd using dracut -fv shows that "resume" module is already included, only the kernel command line parameter is missing.

--- Additional comment from Fedora Blocker Bugs Application on 2015-05-22 05:47:46 EDT ---

Proposed as a Freeze Exception for 22-final by Fedora user krazyabouttechnology using the blocker tracking app because:

 If system is hibernated as part of power management policy or if user manually hibernates the system (using Gnome Shell extension or via command "systemctl hibernate" , on reboot, all the unsaved work is lost as system is not resumed to hibernated state . fsck also runs assuming the partitions are marked dirty.

If hibernate works properly, resume should also work...otherwise system should deny hibernation altogether.

--- Additional comment from Adam Williamson on 2015-06-10 18:20:32 EDT ---

Clearing F22 accepted / nominated freeze exception status as F22 has shipped, per https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Trackers . You may nominate as an Alpha, Beta or Final freeze exception for F23 if desired using the web application - https://qa.fedoraproject.org/blockerbugs/propose_bug (though it is not currently set up for F23) - or by marking the bug as blocking AlphaFreezeException, BetaFreezeException, or FinalFreezeException.

--- Additional comment from Andreas Reschke on 2015-06-24 07:59:28 EDT ---

(In reply to Sumit Bhardwaj from comment #0)
> Description of problem:
> On Fedora Workstation 22 x86_64 RC1 (possibly on RC2 and RC3 as well),
> hibernation using "systemctl hibernate" works out of the box, however
> resuming from hibernated image not happening. The system warm boots instead
> and starts fresh session after running fsck.
> 
> Version-Release number of selected component (if applicable):
> 2.02 beta2
> 
> How reproducible:
> By hibernating the system using standard systemd commands.
> 
> Steps to Reproduce:
> 1. Hibernate the system
> 2. Reboot into Fedora again
> 
> Actual results:
> System boots into a new session after running fsck on all filesystems
> 
> Expected results:
> System resumes the previous hibernated user session.
> 
> Additional info:
> Adding resume=UUID=<UUID> parameter in GRUB_CMDLINE_LINUX variable inside
> /etc/default/grub and doing grub2-mkconfig -o /boot/grub2/grub.cfg resolves
> the issue. Try to regenerate initrd using dracut -fv shows that "resume"
> module is already included, only the kernel command line parameter is
> missing.

On my Laptop (HP Revolve 810) hibernate with luks-encrypted SSD didn't work even with this information. Fresh installation with F22 (x86_64) KDE and up2date packages.

cat /etc/default/grub 
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.lvm.lv=destnadml00_vg/root_lv rd.luks.uuid=luks-9927c3a0-13dd-4a34-ac0f-984d37cd7803 rd.lvm.lv=destnadml00_vg/swap_lv resume=UUID=luks-9927c3a0-13dd-4a34-ac0f-984d37cd7803 rhgb quiet"
GRUB_DISABLE_RECOVERY="true"

cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-4.0.5-300.fc22.x86_64 root=/dev/mapper/destnadml00_vg-root_lv ro rd.lvm.lv=destnadml00_vg/root_lv rd.luks.uuid=luks-9927c3a0-13dd-4a34-ac0f-984d37cd7803 rd.lvm.lv=destnadml00_vg/swap_lv rhgb quiet LANG=de_DE.UTF-8

--- Additional comment from Neil on 2015-07-06 00:04:39 EDT ---



--- Additional comment from Neil on 2015-11-06 09:47:19 EST ---

Present also in Fedora 23.

I think this bug should be rawhide.

--- Additional comment from Francesco Frassinelli (frafra) on 2015-12-28 05:01:31 EST ---

Same here: luks-encrypted SSD with F23 Workstation x86_64.

--- Additional comment from Alex on 2015-12-29 20:52:50 EST ---

I experience similar problem.
Upgraded from Fedora 21 to 22 through # dnf upgrade, I cannot find buttons "Suspend to RAM" and "Hibernate to disk" anymore when I want to turn it off.
Both commands via CLI seem working, but it finds out that only # pm-suspend really accomplishes what it is expected to do, whereas # pm-hibernate shuts down the machine without saving anything.
Very strange, I used them in Fedora 21 without any hassle or glitch, ever!

--- Additional comment from  on 2016-01-28 17:04:47 EST ---

This is the bug report for F22, but the solution works for F23. Same problem.

Bug 1206936

--- Additional comment from Jan Chaloupka on 2016-02-06 16:03:52 EST ---

Confirming the issue is still occurring on the fresh F23. The solution works.

ISO downloaded just today: Fedora-Live-Workstation-x86_64-23-10.iso

--- Additional comment from  on 2016-02-09 00:45:33 EST ---

Apparently the fix doesn't work for me any longer. My laptop reboots or wakes up from hibernation at random after manual hibernation. My F23 installation is about a month old, and the fix worked in the beginning.

--- Additional comment from Brian Lane on 2016-02-09 19:28:59 EST ---

Anaconda needs to add the resume cmdline argument when the system is installed.

--- Additional comment from Neil on 2016-02-14 18:11:21 EST ---

Another confirmation of the simple (but user unfriendly) fix working on an FC23 clean install.

Does the 'Version' on this bug need to be updated for it to be considered for FC24?


Related: the installer automatically gave me an 8GB swap but I have 16GB RAM, if it intends swap to be used for hibernate then it needs to be at least as big as the RAM.
Comment 1 David Shea 2016-02-22 13:05:51 EST
The installer media is not updated after Fedora is released, so there is no need to clone the bug. The issue will be fixed in rawhide.

*** This bug has been marked as a duplicate of bug 1224151 ***

Note You need to log in before you can comment on or make changes to this bug.