Bug 1310421 - Some plugin events run unconditionally
Some plugin events run unconditionally
Status: CLOSED DUPLICATE of bug 1359832
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-setup-plugins (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ovirt-4.1.0-alpha
: ---
Assigned To: Simone Tiraboschi
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-21 07:48 EST by Yedidyah Bar David
Modified: 2016-08-04 06:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-04 06:07:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yedidyah Bar David 2016-02-21 07:48:07 EST
Description of problem:

Most of the events here, e.g. in [1], should run only if engine is enabled.

[1] setup/plugins/ovirt-engine-setup/rhevm-setup-plugins/distro-rhel/config.py

Version-Release number of selected component (if applicable):

Probably since 3.5 or so

How reproducible:

Always I think, didn't try

Steps to Reproduce:
1. Install and setup engine+dwh on machine A
2. Install engine+reports on machine B
3. Run engine-setup on machine B, choose to configure only Reports (using existing engine+dwh from machine A)

Actual results:

I think that some plugins will fail while trying to update vdc options.
Even if in scenarios where they do not, they should not run. E.g. if
machine A has engine and on B we ask to configure only dwh+reports, we'll also have A's engine db credentials, thus probably will not fail, but do not want to update vdc options.

Expected results:

A machine setting up things other than the engine should not touch vdc options.

Additional info:
Comment 1 Yaniv Lavi (Dary) 2016-05-09 06:56:58 EDT
oVirt 4.0 Alpha has been released, moving to oVirt 4.0 Beta target.
Comment 4 Yaniv Lavi (Dary) 2016-06-06 21:59:28 EDT
We will only use GA flag until RHEV GA.
Comment 5 Simone Tiraboschi 2016-08-04 06:07:50 EDT

*** This bug has been marked as a duplicate of bug 1359832 ***

Note You need to log in before you can comment on or make changes to this bug.