Bug 1310425 - Issue with updating manifest of disconnected Satellite via sync host
Issue with updating manifest of disconnected Satellite via sync host
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Inter Satellite Sync (Show other bugs)
Unspecified
All Linux
unspecified Severity urgent (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-21 08:08 EST by jalviso
Modified: 2016-09-21 18:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-21 18:49:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jalviso 2016-02-21 08:08:25 EST
Description of problem:

Issue with updating manifest of disconnected Satellite via sync host. Refresh with latest generated manifest will reult in candlepin error and  make the subscription assign to Activation/Content Host in 'Invalid Subscription' status. 

Version-Release number of selected component (if applicable):

How reproducible: Always.

Steps to Reproduce:
1. Generate a new manifest from Portal (due to subscription addition or other
  reasons).

2. Refresh the newly generated manifest to Disconnected Satellite 6, this will 
   display a message "Owner has already imported from another subscription 
   management application" and candlepin errror is showing:

"Katello::Errors::CandlepinError: Owner has already imported from another subscription management application."

Activation key and Content Host get 'Invalid Subscription' status. 

3. Delete the existing manifest and upload the latest, will lead to go to each 
   activation key/ Content Host and re-add/re-assign the subscription.

Actual results: 

As per Step 2. and 3.
Step 3 is a workaround as documented in the KBase article;
   https://access.redhat.com/solutions/1349373
but with an organization that has 100+ systems and growing, the current solution causes issues with large organization.

Expected results:

Refreshing the manifest should work without error.

Additional info:

Customer is aware that Disiconnected Satellite via sync host will soon be replace with another technology. But until then, customer needs a better resolution.
Comment 2 Bryan Kearney 2016-07-26 15:04:03 EDT
Moving 6.2 bugs out to sat-backlog.

Note You need to log in before you can comment on or make changes to this bug.