Bug 1310447 - Mysterious 8 second delay after grub and before booting
Mysterious 8 second delay after grub and before booting
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-21 11:24 EST by crxssi
Modified: 2016-07-20 23:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-20 23:21:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
systemd-analyze chart (645.03 KB, image/png)
2016-02-21 11:24 EST, crxssi
no flags Details
systemd bootchart (127.52 KB, image/png)
2016-02-21 11:25 EST, crxssi
no flags Details

  None (edit)
Description crxssi 2016-02-21 11:24:15 EST
Created attachment 1129068 [details]
systemd-analyze chart

I have installed Fedora 23 (KDE spin) on an HP Prodesk mini 600 G2. After grub comes up, I press <enter> on any kernel to boot, the screen goes black with a blinking underscore cursor and then there is a mysterious 8 second delay with no messages and no hard drive/SSD activity during that period. Then after the 8 seconds, BAM, there is a flurry of activity over the next 4 seconds and it is finished booting. Try as I may, I can't figure out what that delay is. But I know it shouldn't be there. I am doing nothing special. No RAID, no encryption, just two partitions (root and swap).

Things that made no difference: I uninstalled Plymouth.I tried UEFI vs. Legacy. I tried a Fedora live boot DVD instead of booting from the SDD install. I tried same thing with USB key boot.  Same thing with M.2 PCI SSD boot.  Disabled a bunch of stuff like abrtd and ModemManager. Removed the "quiet" and other flags in the kernel invocation. Rebuilt default initrd with dracut.  Also tried the debug kernel.  I even tried replacing grub with isolinux.  All have the exact same 8 second pause.

I tried booting Fedora 23 on our Lenovo laptops as well (a totally different machine with different chipset and other hardware) and there is an 8 second delay on those too.  Then I tried Fedora 21 on both the HP Prodesk and Lenovo laptops- same 8 second delay!  But if I try a different distro, like Archbang, there is no such delay at all- 4 second boot from pressing <enter> in grub.  

I thought maybe "systemd-analyze" would help, but it doesn't show that delay... it says "4.3 seconds" which is the time AFTER the 8 second delay.  Same thing when I tried init=/usr/lib/systemd/systemd-bootchart, no additional useful information.  Will attach (although not sure it will be useful).

It is a shame that what could be a 4 second boot is taking 12 seconds (300% slowe than it should be).  But what makes it much worse is that there are zero messages or feedback to the user during those 8 seconds... which is a long time for the machine to look and act dead.
Comment 1 crxssi 2016-02-21 11:25 EST
Created attachment 1129069 [details]
systemd bootchart
Comment 2 crxssi 2016-07-15 18:39:45 EDT
Hundreds and hundreds of updates later and still no change.  But since then, Fedora 24 has come out, so I tried it as a test. The mysterious boot delay doesn't happen on 24 with those machines. Fedora 23 is what we are still using and rolling out so it is still an issue for us.
Comment 3 crxssi 2016-07-20 23:21:12 EDT
Turns out there were additional BIOS updates for the HP mini's which I missed.  Installed them and, to my surprise, the 8 second delay is now completely gone!  I tried several tests to make sure it wasn't any Fedora 23 updates, and it wasn't.  No idea why it helped, but at least the problem is finally solved.

Note You need to log in before you can comment on or make changes to this bug.