Bug 1310495 - Kexec fails on Fedora 23 ppc64le
Kexec fails on Fedora 23 ppc64le
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
23
ppc64le Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dave Young
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PPCTracker F-ExcludeArch-ppc64le/PPC64LETracker
  Show dependency treegraph
 
Reported: 2016-02-21 22:03 EST by adi.gangidi
Modified: 2016-04-02 00:20 EDT (History)
9 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.10-10.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-02 00:20:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs in couple of instances where failure is observed. This log changes often resulting in no log at all (1.29 KB, application/zip)
2016-02-21 22:03 EST, adi.gangidi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 139558 None None None 2016-03-23 04:54 EDT

  None (edit)
Description adi.gangidi 2016-02-21 22:03:41 EST
Created attachment 1129123 [details]
Logs in couple of instances where failure is observed. This log changes often resulting in no log at all

Description of problem:

Kexec fails on Fedora 23 ppc64le


We've reproduced a 1-1 Kexec failure on Fedora 23 ppc64le Bare Metal Install (Stock OS). We also tested it on live host OS and also observed that it fails too.  

Here's all the stuff we tried:
​Kexec From   Kexec To       Status
​Fedora 23   ​Fedora 23       ​Failure
​Fedora 23   Ubuntu 15.04    Failure
​Fedora 23   ​Ubuntu 15.10    Failure

Kexec works on following ppc64le Stock Host OS without issues:  Ubuntu 15.10, 15.04, CentOS 7.2 

Kexec Fails on following ppc64le Stock Host OS:    Fedora 23 , Debian 8.3 

Logs:  System hang happens with random logs (More often with no logs at all). I've attached couple of snippets of logs we were able to obtain. 

Version-Release number of selected component (if applicable):

Kernel Version:
[root@ppc-builder ~]# uname -a
Linux ppc-builder 4.2.6-301.fc23.ppc64le #1 SMP Thu Nov 26 19:44:15 UTC 2015 ppc64le ppc64le ppc64le GNU/Linux

OS Version:

[root@ppc-builder ~]# cat /etc/os-release
NAME=Fedora
VERSION="23 (Server Edition)"
ID=fedora
VERSION_ID=23
PRETTY_NAME="Fedora 23 (Server Edition)"
ANSI_COLOR="0;34"
CPE_NAME="cpe:/o:fedoraproject:fedora:23"
HOME_URL="https://fedoraproject.org/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=23
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=23
PRIVACY_POLICY_URL=https://fedoraproject.org/wiki/Legal:PrivacyPolicy
VARIANT="Server Edition"
VARIANT_ID=server

How reproducible:
1-1

Steps to Reproduce:
a.
Install kexec-tools
b. Run: 
kexec -l vmlinuz —initrd=“initrd.img” —command-line=`cat /proc/cmdline`
c. Run:
kexec -e​
d.
Host Console hangs indefinitely, without providing ability to get any logs.

Actual results:
kexec -e results in a system hang (with different logs)

Expected results:
kexec -e should result in reloading of new kernel and initrd provided

Additional info:
Comment 2 Dave Young 2016-02-25 22:45:53 EST
Here is a patch posted to kexec-tools upstream:
http://lists.infradead.org/pipermail/kexec/2016-February/015445.html

I think ubuntu works just because they are using old version of kexec-tools

Thanks
Dave
Comment 3 Dave Young 2016-02-25 22:53:46 EST
Antony, can you retest with my patch in comment #2, It seems another problem in the patches in comment #1, but we may have multiple problems in the report though.
Patch in comment #2 works for me. But I will appreciate for your further testing because it is the only patch I need to make kexec work.

Thanks
Dave
Comment 4 Dave Young 2016-02-26 02:06:07 EST
Antony, sorry, I find my test environment is not correct, I used a latest branch locally. In F23 patch in comment #2 is not necessary. Will see if I can test F23 on a ppc64 machine.
Comment 5 Dave Young 2016-02-26 04:04:38 EST
I reproduced the problem in F23, patches mentioned in comment #1 works, seems I can not reproduce the problem in my patch (comment #2) with Fedora kernel. But it can be easily reproduced with RHEL kernel in Fedora with latest upstream kexec-tools.

Test result like below for me:
Fedora kernel load Fedora kernel: need only the ABI v2 patches.
Fedora kernel load RHEL kernel: need only ABI v2 patches.
Fedora kernel load RHEL kernel with upstream kexec-tools: need both ABI v2 patches and the fs2dt fix in comment #2

So till now for Fedora 23 we should only need the ABI v2 patches, when we rebase kexec-tools in rawhide we may need both.

I'm still not sure why the different kernel version matters. Will discuss it in kexec list further.

Thanks
Dave
Comment 6 Dave Young 2016-03-22 23:10:50 EDT
http://lists.infradead.org/pipermail/kexec/2016-February/015446.html
http://lists.infradead.org/pipermail/kexec/2016-February/015447.html
http://lists.infradead.org/pipermail/kexec/2016-February/015448.html

Above is the upstream patches, but it need review from powerpc people.

Any of IBM people in cc list can help review them?

Thanks
Dave
Comment 8 Dave Young 2016-03-24 02:27:06 EDT
Cool, thanks a lot. Will post patch for Fedora 24 kexec-tools.

adi.gangidi@rackspace.com, do you need it in Fedora 23?

Thanks
Dave
Comment 9 Antony Messerli 2016-03-24 11:05:05 EDT
Yes, if we could please.  We're actively working with Fedora 23 and would like do some more testing with it.  If it's too much trouble, I can always get a build in copr.

Thanks for everyone's help so far!
Comment 10 Dave Young 2016-03-24 21:00:04 EDT
Ok, will fix it in f23 as well.
Comment 11 Fedora Update System 2016-03-24 22:52:26 EDT
kexec-tools-2.0.10-10.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4e3a1242aa
Comment 12 Fedora Update System 2016-03-26 11:19:40 EDT
kexec-tools-2.0.10-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4e3a1242aa
Comment 13 Fedora Update System 2016-04-02 00:20:30 EDT
kexec-tools-2.0.10-10.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.