Bug 1310525 - package cannot update due to numerous conflicts
package cannot update due to numerous conflicts
Status: CLOSED DUPLICATE of bug 1310441
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Staněk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 01:34 EST by Kriton Kyrimis
Modified: 2016-02-23 09:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 09:45:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kriton Kyrimis 2016-02-22 01:34:10 EST
Description of problem:
The latest update of sqlite cannot be installed, due to conflicts with other packages, which require the previous version.


Version-Release number of selected component (if applicable):
3.11.0-1.fc23


How reproducible:


Steps to Reproduce:
1. dnf update

Actual results:
Last metadata expiration check performed 0:39:09 ago on Mon Feb 22 07:46:33 2016.
Dependencies resolved.
================================================================================================================================
 Package                         Arch                      Version                             Repository                  Size
================================================================================================================================
Skipping packages with broken dependencies:
 sqlite                          x86_64                    3.11.0-1.fc23                       updates                    484 k
 sqlite-devel                    x86_64                    3.11.0-1.fc23                       updates                    129 k

Transaction Summary
================================================================================================================================
Skip  2 Packages

Nothing to do.
Complete!


Downloading the packages using "dnf download" and trying to install them by hand, using rpm, produces a bunch of conflicts:

error: Failed dependencies:
	sqlite-libs = 3.11.0-1.fc23 is needed by sqlite-3.11.0-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) python-libs-2.7.10-8.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) python3-libs-3.4.3-5.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) zeitgeist-libs-0.9.16-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) gom-0.3.1-2.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) redland-1.0.17-4.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) libchewing-0.4.0-5.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) telepathy-logger-0.8.2-2.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) akonadi-1.13.0-20.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) qtwebkit-2.3.4-8.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) webkitgtk-2.4.9-3.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) qt5-qtwebkit-5.5.1-4.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) telepathy-gabble-0.18.2-5.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) telepathy-salut-0.8.1-8.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) yum-metadata-parser-1.1.4-15.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) colord-1.2.12-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) hugin-base-2015.0.0-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) systemtap-client-2.9-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) systemtap-devel-2.9-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) libgpod-0.8.3-10.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) webkitgtk3-2.4.9-3.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) folks-1:0.11.1-3.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) libchamplain-0.12.11-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) yelp-libs-2:3.17.2-3.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) yelp-2:3.17.2-3.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) gnome-software-3.18.3-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) gnome-contacts-3.18.1-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) libsoup-2.52.2-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) gnome-shell-3.18.3-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) bijiben-3.18.2-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) fwupd-0.5.4-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) PackageKit-glib-1.0.11-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) PackageKit-1.0.11-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) PackageKit-gstreamer-plugin-1.0.11-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) PackageKit-command-not-found-1.0.11-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) lshw-B.02.17-6.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) lshw-gui-B.02.17-6.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) tracker-1.6.1-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) qt-1:4.8.7-5.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) simple-scan-3.18.2-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) rygel-0.28.2-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) filezilla-3.14.1-2.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) subversion-libs-1.9.3-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) subversion-1.9.3-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) grilo-plugins-0.2.17-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) ibus-libpinyin-1.7.4-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) font-manager-0.7.2-3.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) mate-applet-softupd-0.4.2-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) qt5-qtbase-5.5.1-11.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) epiphany-runtime-1:3.18.3-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) shotwell-0.23.0-0.1.20160105gitf2fb1f7.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) nfs-utils-1:1.3.3-6.rc3.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) evolution-data-server-3.18.4-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) evolution-3.18.4-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) evolution-ews-3.18.4-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) setools-libs-3.3.8-8.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) webkitgtk4-2.10.7-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) webkitgtk4-devel-2.10.7-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) createrepo_c-libs-0.10.0-2.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) createrepo_c-0.10.0-2.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) mame-0.170-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) nss-softokn-3.22.0-1.0.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) calligra-kexi-2.9.11-3.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) firefox-44.0.2-3.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) avidemux-libs-2.6.10-3.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) glusterfs-server-3.7.8-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by (installed) thunderbird-38.6.0-1.fc23.x86_64
	libsqlite3.so.0()(64bit) is needed by sqlite-devel-3.11.0-1.fc23.x86_64

(I would assume that the list is not exhaustive, but depends on what other packages are installed on the system.)


Expected results:

The package is updated, and all packages that require it are updated as well.


Additional info:
There is no update for sqlite.i686, which is still at version 3.8.11. Perhaps the x86_64 version was released by mistake.
Comment 1 Felix Schwarz 2016-02-23 08:35:33 EST
If you have sqlite.i686 on your system then I suspect it is a duplicate of bug 1310441. Can you check if you have the i686 version of sqlite installed?
Comment 2 Kriton Kyrimis 2016-02-23 08:55:00 EST
Yes, I do have the i686 version of sqlite installed.
Comment 3 Nils Philippsen 2016-02-23 09:45:53 EST
Closing as duplicate then.

*** This bug has been marked as a duplicate of bug 1310441 ***

Note You need to log in before you can comment on or make changes to this bug.