Bug 1310527 - [libreoffice] Please add Supplements tag in specfile
[libreoffice] Please add Supplements tag in specfile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1314406
  Show dependency treegraph
 
Reported: 2016-02-22 01:58 EST by Parag Nemade
Modified: 2016-03-03 09:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-26 01:07:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add Supplements for langpacks namimg guidelines (1.31 KB, patch)
2016-02-22 01:58 EST, Parag Nemade
no flags Details | Diff

  None (edit)
Description Parag Nemade 2016-02-22 01:58:06 EST
Created attachment 1129152 [details]
Add Supplements for langpacks namimg guidelines

Description of problem:
As per newly approved https://fedoraproject.org/wiki/PackagingDrafts/Langpack guidelines in https://fedorahosted.org/fpc/ticket/593#comment:18 , I would like to request to please commit the attached patch so that langpacks installation will be helpful.

I am trying to build libreoffice using this patch since last 2 days in copr but somehow current changes are not building in copr, almost 4-5 builds failed due to either some missing BR deps as seen in root.log or some other issues with last built -3 rebuild in copr.
Comment 1 David Tardon 2016-02-22 02:42:30 EST
The attached patch is wrong for several reasons:
1. it does not take epoch into account;
2. it unconditionally uses the libreoffice language tags instead of glibc tags
3. (not your fault, as you can't know we do this) not usable on RHEL-7, because rpm there doesn't even understand weak deps, much less rich deps

Also, I see no reason to do this for autocorr packages as well--they are pulled in by respective langpacks.

I'm running a scratch build now...
Comment 2 Jan Kurik 2016-02-24 10:28:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.