Bug 1310545 - System Python
System Python
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
ChangeAcceptedF24, SelfContainedChange
:
Depends On:
Blocks: base-minimization
  Show dependency treegraph
 
Reported: 2016-02-22 03:21 EST by Jan Kurik
Modified: 2016-07-22 04:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: python3-3.5.1-6.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-21 16:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-02-22 03:21:07 EST
This is a tracking bug for Change: System Python
For more details, see: https://fedoraproject.org//wiki/Changes/System_Python

Separate several subpackages form the python3 packages - a system-python(-libs) that can be required by various tools that consider themselves "system tools".
Comment 1 Jan Kurik 2016-02-24 09:26:24 EST
On 2016-Feb-23, we have reached Fedora 24 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Completion deadline.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo on 2016-Feb-26 meeting.  Contingency plan for System Wide Changes, if planned for Alpha (or in case of serious doubts regarding Change completion), will be activated.
Comment 2 David Lehman 2016-03-15 11:28:21 EDT
(In reply to Jan Kurik from comment #0)
> This is a tracking bug for Change: System Python
> For more details, see: https://fedoraproject.org//wiki/Changes/System_Python

The change page lists space savings as the only benefit and never states the goal of having a separate version of python for system tools (at least it eluded me when I read over it). A bit misleading IMO.
Comment 3 Petr Viktorin 2016-03-15 11:32:29 EDT
A separate version of Python for system tools is not the goal here; system-python only has a subset of the standard library from Fedora's default Python3.
Comment 5 Yaakov Selkowitz 2016-04-11 17:34:46 EDT
What was not clearly defined in this proposal was the definition of "system tool", nor how other packages should use it.

For instance, dnf and its various dependencies are using python3.  Can/should they all be using system-python so as to save space from a minimal system (e.g. Docker base image)?
Comment 6 Miro Hrončok 2016-04-11 18:25:50 EDT
They can, and we'll talk to them about his. But not in F24 scope. A demo is here: https://copr.fedorainfracloud.org/coprs/churchyard/system-python-demo/

The scope of this change is just to provide the means to do so. Hence the self contained change status.
Comment 7 Yaakov Selkowitz 2016-04-15 01:27:36 EDT
(In reply to Miro Hrončok from comment #6)
> They can, and we'll talk to them about his. But not in F24 scope. A demo is
> here: https://copr.fedorainfracloud.org/coprs/churchyard/system-python-demo/

Thanks!  That was very useful in helping us get python3 out of the Docker base image, for a savings of ~20MB, and dnf still worked fine AFAICS.  It would be great to see these patches start hitting rawhide.  What are your plans for doing so?

(BTW, I think the same could be done for dnf-plugins-core; I didn't test everything but repoquery worked fine when built with %{system_python_abi}.)
Comment 8 Petr Viktorin 2016-04-15 04:52:46 EDT
(In reply to Yaakov Selkowitz from comment #7)
> It would be great to see these patches start hitting rawhide.  What are
> your plans for doing so?

Due to Miro's other commitments, the plan is to start talking to DNF people around half of May.
Comment 9 Jan Kurik 2016-04-20 11:01:50 EDT
On 2016-Apr-19 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 24 release. At this point all the Changes not at least in in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan
Comment 10 Petr Viktorin 2016-04-21 04:21:52 EDT
The change is already in Fedora. As explained in the Change, no other packages should be affected at this point.
Comment 11 Brendan Conoboy 2016-07-21 15:45:12 EDT
With F24 released and including system-python 3.5 is this BZ complete?
Comment 12 Miro Hrončok 2016-07-21 16:18:59 EDT
Yes
Comment 13 Yaakov Selkowitz 2016-07-21 18:54:49 EDT
(In reply to Brendan Conoboy from comment #11)
> With F24 released and including system-python 3.5 is this BZ complete?
(In reply to Miro Hrončok from comment #12)
> Yes

What this bug does not cover (per comment 6) is the usage of system-python in the dnf stack.  Have those bugs been filed yet?
Comment 14 Miro Hrončok 2016-07-22 04:11:10 EDT
(In reply to Yaakov Selkowitz from comment #13)
> What this bug does not cover (per comment 6) is the usage of system-python
> in the dnf stack.  Have those bugs been filed yet?

Nope, we are having a discussion with the dnf team and currently are trying to make sure dnf is testable on system Python. Once the discussion is over, we'll open bugs.

Note You need to log in before you can comment on or make changes to this bug.