Bug 1310560 - [tempest] OSPD Director should provide TEMPEST_STORAGE_PROTOCOL to deployer-input file
[tempest] OSPD Director should provide TEMPEST_STORAGE_PROTOCOL to deployer-i...
Status: CLOSED DUPLICATE of bug 1291568
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
unspecified
All Linux
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: Angus Thomas
Arik Chernetsky
: Automation, AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 03:58 EST by Daniel Mellado
Modified: 2016-02-29 03:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 03:24:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mellado 2016-02-22 03:58:21 EST
Description of problem:

When having ceph or another non-standard volume backend, tempest needs to be configured differently. Cinder admin tests have backend related options and unless the tempest-config tool is provided with some hints it won't be able to figure on its own.

Upstream, devstack gets provided with the following options:
https://github.com/openstack-dev/devstack/blob/master/lib/tempest#L69-L74

So for this case we'd need OSP-Director to specifically provide tempest with the following option:

TEMPEST_STORAGE_PROTOCOL=ceph

In order for it to run properly, as it can't discover this on its own.
Comment 2 tkammer 2016-02-29 03:24:51 EST

*** This bug has been marked as a duplicate of bug 1291568 ***

Note You need to log in before you can comment on or make changes to this bug.