Bug 1310597 - Tempest tests fails with multiple HTTP exception errors "Instance could not be found"
Tempest tests fails with multiple HTTP exception errors "Instance could not b...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity high
: ---
: 6.0 (Juno)
Assigned To: Lee Yarwood
nlevinki
: ZStream
: 1304430 1312326 (view as bug list)
Depends On:
Blocks: 1322858
  Show dependency treegraph
 
Reported: 2016-02-22 05:33 EST by Michal Pryc
Modified: 2018-02-08 06:15 EST (History)
16 users (show)

See Also:
Fixed In Version: openstack-nova-2014.2.3-60.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1322858 (view as bug list)
Environment:
Last Closed: 2016-03-23 10:26:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Lee Yarwood 2016-02-22 05:39:52 EST
Description of problem:

/var/log/nova/nova-api.log

 244 2016-02-21 00:56:17.628 31526 ERROR nova.network.base_api [req-210c96fa-e983-44d7-9bd6-b07514601a21 None] [instance: a5d2db26-7627-4307-b6e7-174863ac7fc4] Failed storing info cache
 245 2016-02-21 00:56:17.628 31526 TRACE nova.network.base_api [instance: a5d2db26-7627-4307-b6e7-174863ac7fc4] Traceback (most recent call last):
 246 2016-02-21 00:56:17.628 31526 TRACE nova.network.base_api [instance: a5d2db26-7627-4307-b6e7-174863ac7fc4]   File "/usr/lib/python2.7/site-packages/nova/network/base_api.py", line 39, in update_instance_cache_with_nw_info
 247 2016-02-21 00:56:17.628 31526 TRACE nova.network.base_api [instance: a5d2db26-7627-4307-b6e7-174863ac7fc4]     nw_info = impl._get_instance_nw_info(context, instance)
 248 2016-02-21 00:56:17.628 31526 TRACE nova.network.base_api [instance: a5d2db26-7627-4307-b6e7-174863ac7fc4]   File "/usr/lib/python2.7/site-packages/nova/network/neutronv2/api.py", line 615, in _get_instance_nw_info
 249 2016-02-21 00:56:17.628 31526 TRACE nova.network.base_api [instance: a5d2db26-7627-4307-b6e7-174863ac7fc4]     compute_utils.refresh_info_cache_for_instance(context, instance)
 250 2016-02-21 00:56:17.628 31526 TRACE nova.network.base_api [instance: a5d2db26-7627-4307-b6e7-174863ac7fc4]   File "/usr/lib/python2.7/site-packages/nova/compute/utils.py", line 411, in refresh_info_cache_for_instance
 251 2016-02-21 00:56:17.628 31526 TRACE nova.network.base_api [instance: a5d2db26-7627-4307-b6e7-174863ac7fc4]     if instance.info_cache is not None:
 252 2016-02-21 00:56:17.628 31526 TRACE nova.network.base_api [instance: a5d2db26-7627-4307-b6e7-174863ac7fc4] AttributeError: 'dict' object has no attribute 'info_cache'
 253 2016-02-21 00:56:17.628 31526 TRACE nova.network.base_api [instance: a5d2db26-7627-4307-b6e7-174863ac7fc4]  
 254 2016-02-21 00:56:17.630 31526 ERROR nova.api.openstack.compute.contrib.floating_ips [req-210c96fa-e983-44d7-9bd6-b07514601a21 None] Unable to associate floating ip 172.31.1.49 to fixed ip 10.100.0.2 for instance a5d2db26-7627-4307-b6e7-174863ac7fc4. Error: 'dict' ob     ject has no attribute 'info_cache' 
 255 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips Traceback (most recent call last):
 256 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips   File "/usr/lib/python2.7/site-packages/nova/api/openstack/compute/contrib/floating_ips.py", line 240, in _add_floating_ip
 257 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips     fixed_address=fixed_address)
 258 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips   File "/usr/lib/python2.7/site-packages/nova/network/base_api.py", line 75, in wrapper
 259 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips     nw_info=res)
 260 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips   File "/usr/lib/python2.7/site-packages/nova/hooks.py", line 131, in inner
 261 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips     rv = f(*args, **kwargs)
 262 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips   File "/usr/lib/python2.7/site-packages/nova/network/base_api.py", line 49, in update_instance_cache_with_nw_info 
 263 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips     LOG.exception(_('Failed storing info cache'), instance=instance)
 264 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips   File "/usr/lib/python2.7/site-packages/nova/openstack/common/excutils.py", line 82, in __exit__
 265 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips     six.reraise(self.type_, self.value, self.tb)
 266 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips   File "/usr/lib/python2.7/site-packages/nova/network/base_api.py", line 39, in update_instance_cache_with_nw_info
 267 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips     nw_info = impl._get_instance_nw_info(context, instance)
 268 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips   File "/usr/lib/python2.7/site-packages/nova/network/neutronv2/api.py", line 615, in _get_instance_nw_info
 269 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips     compute_utils.refresh_info_cache_for_instance(context, instance)
 270 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips   File "/usr/lib/python2.7/site-packages/nova/compute/utils.py", line 411, in refresh_info_cache_for_instance
 271 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips     if instance.info_cache is not None:
 272 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips AttributeError: 'dict' object has no attribute 'info_cache'
 273 2016-02-21 00:56:17.630 31526 TRACE nova.api.openstack.compute.contrib.floating_ips 
 274 2016-02-21 00:56:17.630 31526 INFO nova.api.openstack.wsgi [req-210c96fa-e983-44d7-9bd6-b07514601a21 None] HTTP exception thrown: Unable to associate floating ip 172.31.1.49 to fixed ip 10.100.0.2 for instance a5d2db26-7627-4307-b6e7-174863ac7fc4. Error: 'dict' object has no attribute 'info_cache'

Version-Release number of selected component (if applicable):
opesntack-nova-2014.2.3-59.el7ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. Run temptest tests.

Actual results:

The following tests fail :
- tempest.scenario.test_minimum_basic.TestMinimumBasicScenario.test_minimum_basic_scenario[compute,id-bdbb5441-9204-419d-a225-b4fdbfb1a1a8,image,network,volume]
- tempest.scenario.test_shelve_instance.TestShelveInstance.test_shelve_instance[compute,id-1164e700-0af0-4a4c-8792-35909a88743c,image,network]
- tempest.scenario.test_shelve_instance.TestShelveInstance.test_shelve_volume_backed_instance[compute,id-c1b6318c-b9da-490b-9c67-9339b627271f,image,network,volume]
	
Expected results:
No tests fail.

Additional info:
Comment 4 Lee Yarwood 2016-02-26 10:59:51 EST
*** Bug 1312326 has been marked as a duplicate of this bug. ***
Comment 11 errata-xmlrpc 2016-03-23 10:26:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0500.html
Comment 12 Lee Yarwood 2016-04-03 05:11:51 EDT
*** Bug 1304430 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.