Bug 1310617 - Assertion 'clock_gettime(clock_id, &ts) == 0' failed at src/basic/time-util.c:48, function now(). Aborting.
Assertion 'clock_gettime(clock_id, &ts) == 0' failed at src/basic/time-util.c...
Status: CLOSED DUPLICATE of bug 1310800
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
aarch64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARM64/F-ExcludeArch-aarch64
  Show dependency treegraph
 
Reported: 2016-02-22 06:11 EST by Marcin Juszkiewicz
Modified: 2016-02-23 02:47 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 02:47:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Juszkiewicz 2016-02-22 06:11:47 EST
Description of problem:

Build of systemd fails on aarch64:

FAIL: test-event
================

got IO on d
got IO on d
preparing c
preparing a
got IO on b
preparing c
preparing a
got timer on c
preparing a
got IO on a
preparing c
got timer on c
got post handler
got defer on d
got post handler
got signal on e
got post handler
got child on f
got quit handler on g
Assertion 'clock_gettime(clock_id, &ts) == 0' failed at src/basic/time-util.c:48, function now(). Aborting.
FAIL test-event (exit status: 134)

Version-Release number of selected component (if applicable):

229-2.fc24

How reproducible:

always

Steps to Reproduce:
1. do a build on aarch64 (arm-koji is enough for scratch builds)
2.
3.

Actual results:

package fails to build

Expected results:

package builds

Additional info:
Comment 1 Jan Synacek 2016-02-22 06:42:04 EST
Do you have a machine that I could use to play around with this?
Comment 2 Peter Robinson 2016-02-22 06:48:02 EST
(In reply to Jan Synacek from comment #1)
> Do you have a machine that I could use to play around with this?

There's HW available in beaker generally, I think we see the same issue on PPC too
Comment 3 Marcin Juszkiewicz 2016-02-22 07:23:20 EST
And this is not toolchain related as I see exactly same failure with 229-2 build in Fedora 23 aarch64 mock (gcc 5.1.1, binutils 2.25).

Booted kernel 4.4.0-rc8.
Comment 4 Jan Synacek 2016-02-23 02:47:34 EST

*** This bug has been marked as a duplicate of bug 1310800 ***

Note You need to log in before you can comment on or make changes to this bug.