Bug 131062 - battery status applet resets laptop
battery status applet resets laptop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-26 21:34 EDT by Jeffrey C. Ollie
Modified: 2015-01-04 17:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 15:08:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of 'lshal' on 8/27/04 10:45am CST (37.01 KB, text/plain)
2004-08-27 11:43 EDT, Jeffrey C. Ollie
no flags Details

  None (edit)
Description Jeffrey C. Ollie 2004-08-26 21:34:40 EDT
Description of problem:
Adding the battery status applet to panel causes laptop to hard reset.

Version-Release number of selected component (if applicable):
gnome-panel-2.7.91.1-2
kernel-2.6.8-1.526

How reproducible:
100%

Steps to Reproduce:
1. add the battery status applet to the panel
2.
3.
  
Actual results:
Laptop hard resets.

Expected results:
Able to monitor battery status through applet.

Additional info:
Compaq Evo N800c upgraded to latest rawhide as of 8/26/04.
Comment 1 Warren Togami 2004-08-27 03:26:17 EDT
This is a kernel, perhaps ACPI problem.  Can you please provide more
technical specifications about your laptop's chipset, processor,
video, etc.
Comment 2 Jeffrey C. Ollie 2004-08-27 09:28:31 EDT
Processor: Intel Pentium 4 M 2.2Ghz
Chipset: Intel 845 Brookdale
Video: ATI Radeon Mobility M7 LW
Ram: 1GB

Also, I forgot to note that this problem did not occur on 8/25/04,
only after I installed latest rawhide updates from 8/26/04.  SELinux
is disabled as well.

I noticed that there is a BIOS upgrade from HP for the notebook.  I'm
going to give that a try but I have to boot from the Windows XP
partition to install it.
Comment 3 Jeffrey C. Ollie 2004-08-27 09:59:42 EDT
Upgrading the BIOS from F.1D to F.23 and did not fix the problem. 
Going to try and upgrade to rawhide from 8/27/04 to see if that helps.
Comment 4 Jeffrey C. Ollie 2004-08-27 11:40:50 EDT
I upgraded to rawhide as of 8/27/04 and the problem persists.  I also
tried booting into kernel-2.6.8-1.524 and had the same problem.
Comment 5 Jeffrey C. Ollie 2004-08-27 11:43:36 EDT
Created attachment 103167 [details]
output of 'lshal' on 8/27/04 10:45am CST
Comment 6 Jeffrey C. Ollie 2004-08-27 12:01:38 EDT
Hmmm... Running the following command, even as a normal user causes my
laptop to reset:

cat /proc/acpi/battery/C132/state
Comment 7 Jeffrey C. Ollie 2004-08-27 12:20:20 EDT
I also tried the command from a text console to see if I was missing a
kernel oops or something but no luck.  A few seconds after you run the
command the laptop resets, no oops message, no nothin'.
Comment 8 Jeffrey C. Ollie 2004-08-27 12:34:04 EDT
I tried replacing the battery with a battery from a co-worker's laptop
- same problem.
Comment 9 Jeffrey C. Ollie 2004-08-29 15:50:04 EDT
I've now tried with these kernels:

kernel-2.6.7-1.515
kernel-2.6.7-1.517
kernel-2.6.8-1.524
kernel-2.6.8-1.526
kernel-2.6.8-1.532
kernel-2.6.8-1.533

and all will reset the laptop shortly after accessing
"/proc/acpi/battery/C132/state"

I also booted into Windows XP Professional (completely updated except
for SP2) and was able to use XP's battery status panel without any
problems.
Comment 10 Warren Togami 2004-08-29 17:10:17 EDT
Red Hat does not have the time resources to investigate your problem.
 You should go directly to the authors of ACPI on the acpi-devel
mailing list.  Reference this existing report when you report your
problem.

http://acpi.sourceforge.net/
Plenty of details here.
Comment 11 Jeffrey C. Ollie 2004-08-29 20:49:50 EDT
Posted to kernel bugzilla:

http://bugzilla.kernel.org/show_bug.cgi?id=3308
Comment 12 Jeffrey C. Ollie 2005-04-05 15:08:33 EDT
Cleaning up this bug... was resolved with later versions... plus I no longer
have access to the specific laptop that was having the problem.

Note You need to log in before you can comment on or make changes to this bug.