Bug 1310621 - [RFE] oVirt Guest Tools name should include version in install apps list
[RFE] oVirt Guest Tools name should include version in install apps list
Status: CLOSED CURRENTRELEASE
Product: ovirt-guest-tools
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
low Severity unspecified (vote)
: ovirt-4.1.0-alpha
: 4.1.0
Assigned To: Yedidyah Bar David
Petr Matyáš
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 06:31 EST by Jiri Belka
Modified: 2017-05-11 05:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-01 09:56:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
pmatyas: testing_plan_complete+
mgoldboi: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 62925 master MERGED Add Display Version as a postfix to the Display Name. 2016-09-05 04:29 EDT

  None (edit)
Description Jiri Belka 2016-02-22 06:31:07 EST
Description of problem:

oVirt Guest Tools name should include version in install apps list. this is the case for d/w tools.

- current:

        appsList = ['PuTTY release 0.66', '7-Zip 15.14', 'oVirt Guest Tools', 'Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17']

- desired:

        appsList = ['PuTTY release 0.66', '7-Zip 15.14', 'oVirt Guest Tools 3.6.0-0.2_master.fc22', 'Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17']

Version-Release number of selected component (if applicable):
3.6.x

How reproducible:
100%

Steps to Reproduce:
1. install ovirt guest tools
2. check installed apps list if 'Name' column has version included
3.

Actual results:
ovirt guest tools in installed apps list does not include version in 'Name' column

Expected results:
ovirt guest tools in installed apps list should include version in 'Name' column

Additional info:
Comment 1 Petr Matyáš 2016-11-28 09:24:49 EST
Only edited existing test plan
Comment 2 Sandro Bonazzola 2016-12-12 09:00:29 EST
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.
Comment 3 Petr Matyáš 2017-01-03 08:05:56 EST
Can you please check test plan modifications (search for 'version' in that document) and change testing_plan_complete flag to '+'?
Comment 4 Yedidyah Bar David 2017-01-04 05:57:46 EST
(In reply to Petr Matyáš from comment #3)
> Can you please check test plan modifications (search for 'version' in that
> document) and change testing_plan_complete flag to '+'?

This bug specifically talks about the version of the guest tools, not "apps" in general. Perhaps:

s/Check that version of apps is reported/Check that version of oVirt Guest Tools is reported/
Comment 5 Petr Matyáš 2017-01-10 12:11:31 EST
I don't see reason behind changing this to guest tools version only since all apps are reporting versions. (And I'm definitely not changing it for the sake of this bug)

Either way, verified on 4.0.6-8 and 4.1.0.
Comment 6 Yedidyah Bar David 2017-01-11 01:41:11 EST
(In reply to Petr Matyáš from comment #5)
> I don't see reason behind changing this to guest tools version only since
> all apps are reporting versions. (And I'm definitely not changing it for the
> sake of this bug)

If you also check guest tools version, fine with me.

All apps already reported versions before current bug, except for the guest tools.

> 
> Either way, verified on 4.0.6-8 and 4.1.0.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.