Bug 1310626 - [engine-backend] NPE during ChangeVDSCluster
[engine-backend] NPE during ChangeVDSCluster
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra (Show other bugs)
3.6.3.2
x86_64 Unspecified
high Severity urgent (vote)
: ovirt-3.6.5
: ---
Assigned To: Yevgeny Zaspitsky
Pavel Stehlik
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 06:41 EST by Elad
Modified: 2016-02-25 07:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 07:36:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
danken: ovirt‑3.6.z?
rule-engine: blocker?
ebenahar: planning_ack?
masayag: devel_ack+
ebenahar: testing_ack?


Attachments (Terms of Use)
engine and server logs (135.57 KB, application/x-gzip)
2016-02-22 06:41 EST, Elad
no flags Details

  None (edit)
Description Elad 2016-02-22 06:41:55 EST
Created attachment 1129250 [details]
engine and server logs

Description of problem:
Changed one of the host's clusters from cluster creation wizard in Webadmin and got a general command failure in UI accompanied by a NullPointerException.
The Host cluster remains the old one, the operation failed.

Version-Release number of selected component (if applicable):
rhevm-3.6.3.2-0.1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Have a host in maintenance
2. Create a new DC and cluster from the DC and cluster creation wizard
3. Pick 'Select host' with the host in maintenance

Actual results:
Getting a 'general command failure' in UI with a NullPointerException in engine.log:

2016-02-22 11:36:13,421 INFO  [org.ovirt.engine.core.bll.ChangeVDSClusterCommand] (ajp-/127.0.0.1:8702-3) [2fcf61e1] Lock Acquired to object 'EngineLock:{exclusiveLocks='[58ff7df3-4e94-4a81-b3ef-4bd18ae42a0d=<VDS,
 ACTION_TYPE_FAILED_OBJECT_LOCKED>]', sharedLocks='null'}'
2016-02-22 11:36:13,426 ERROR [org.ovirt.engine.core.bll.ChangeVDSClusterCommand] (ajp-/127.0.0.1:8702-3) [2fcf61e1] Error during CanDoActionFailure.: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.ChangeVDSClusterCommand.isSameManagementNetwork(ChangeVDSClusterCommand.java:225) [bll.jar:]
        at org.ovirt.engine.core.bll.ChangeVDSClusterCommand.canDoAction(ChangeVDSClusterCommand.java:160) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.internalCanDoAction(CommandBase.java:791) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.canDoActionOnly(CommandBase.java:352) [bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner.canRunActions(MultipleActionsRunner.java:103) [bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner.invokeCommands(MultipleActionsRunner.java:91) [bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner.execute(MultipleActionsRunner.java:63) [bll.jar:]


The Host cluster remains the old one, the operation failed.

Expected results:
Host cluster should change successfully.

Additional info:
engine and server logs
Comment 1 Elad 2016-02-22 06:47:30 EST
Happens also from Hosts tab -> edit host. Cannot change host cluster at all (from Webadmin).
Therefore, changing severity to urgent.
Comment 2 Oved Ourfali 2016-02-22 06:49:42 EST
Please share ALL logs from the logs directory in the engine.
Comment 3 Elad 2016-02-22 07:03:05 EST
All /var/log/ content from engine:
http://file.tlv.redhat.com/ebenahar/bug2.tar.gz
Comment 4 Red Hat Bugzilla Rules Engine 2016-02-24 04:23:46 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 5 Yevgeny Zaspitsky 2016-02-24 05:47:28 EST
Elad,

Please explain the scenario:
1. How the environment was created? Was that a fresh install or an upgrade?
2. What cluster the host belongs prior moving it to the new one? Is this a valid cluster (belongs to a DC)? Is cluster management network defined properly?
Comment 6 Elad 2016-02-25 02:26:30 EST
(In reply to Yevgeny Zaspitsky from comment #5)
> Elad,
> 
> Please explain the scenario:
> 1. How the environment was created? Was that a fresh install or an upgrade?
Upgrade 
> 2. What cluster the host belongs prior moving it to the new one? Is this a
> valid cluster (belongs to a DC)? Is cluster management network defined
> properly?
The host was part of a valid cluster belongs to a DC. no special network configured in these clusters, only the management network. The host was Up in the first cluster
Comment 7 Yevgeny Zaspitsky 2016-02-25 07:36:00 EST
The problem isn't reproducible.

Note You need to log in before you can comment on or make changes to this bug.