Bug 1310636 - team slaves not started after service restart
team slaves not started after service restart
Status: CLOSED DUPLICATE of bug 1294728
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager (Show other bugs)
7.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Rashid Khan
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 07:14 EST by Vladimir Benes
Modified: 2016-04-13 05:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 05:03:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2016-02-22 07:14:17 EST
Description of problem:
team slaves are not correctly upped when NM service restarted. Instead assumed profiles are created and connected.


Version-Release number of selected component (if applicable):
NetworkManager-1.0.6-27.el7.x86_64

[root@wlan-r2s22 control-center]# systemctl restart NetworkManager
[root@wlan-r2s22 control-center]# nmcli d
DEVICE  TYPE      STATE         CONNECTION 
eth0    ethernet  connected     testeth0   
eth1    ethernet  disconnected  --         
eth10   ethernet  disconnected  --         
eth2    ethernet  disconnected  --         
eth3    ethernet  disconnected  --         
eth4    ethernet  disconnected  --         
eth5    ethernet  disconnected  --         
eth6    ethernet  disconnected  --         
eth7    ethernet  disconnected  --         
eth8    ethernet  disconnected  --         
eth9    ethernet  disconnected  --         
wlan0   wifi      disconnected  --         
lo      loopback  unmanaged     --         
[root@wlan-r2s22 control-center]# nmcli connection add type team ip4 1.2.3.4/24
Connection 'team' (88d65e3e-7b2e-4a2b-ada6-15d72d9a84dc) successfully added.
[root@wlan-r2s22 control-center]# nmcli connection add type team-slave ifname eth7 master nm-team 
Connection 'team-slave-eth7' (91716c27-1b94-4004-af33-c1ccc1560799) successfully added.
[root@wlan-r2s22 control-center]# nmcli connection add type team-slave ifname eth8 master nm-team 
Connection 'team-slave-eth8' (66dd59c6-1f12-4143-9af8-2bd1cc57b609) successfully added.
[root@wlan-r2s22 control-center]# nmcli connection s -a
NAME             UUID                                  TYPE            DEVICE  
testeth0         25059774-c2c3-4afa-8ab2-e12d5e09130b  802-3-ethernet  eth0    
team-slave-eth8  66dd59c6-1f12-4143-9af8-2bd1cc57b609  802-3-ethernet  eth8    
team-slave-eth7  91716c27-1b94-4004-af33-c1ccc1560799  802-3-ethernet  eth7    
team             88d65e3e-7b2e-4a2b-ada6-15d72d9a84dc  team            nm-team 
[root@wlan-r2s22 control-center]# systemctl restart NetworkManager
[root@wlan-r2s22 control-center]# nmcli connection s -a
NAME      UUID                                  TYPE            DEVICE  
eth7      3d30dda3-eaa9-4cf4-a84a-2a7b9f5be050  802-3-ethernet  eth7    
testeth0  25059774-c2c3-4afa-8ab2-e12d5e09130b  802-3-ethernet  eth0    
eth8      14d5575e-2e43-401c-b7f1-5ee8a6eaeef5  802-3-ethernet  eth8    
nm-team   542e043e-8423-4873-aa06-3f8e1ca4096e  team            nm-team 
[root@wlan-r2s22 control-center]# nmcli connection show eth7
connection.id:                          eth7
connection.uuid:                        3d30dda3-eaa9-4cf4-a84a-2a7b9f5be050
connection.interface-name:              eth7
connection.type:                        802-3-ethernet
connection.autoconnect:                 no
connection.autoconnect-priority:        0
connection.timestamp:                   1456143105
connection.read-only:                   no
connection.permissions:                 
connection.zone:                        --
connection.master:                      nm-team
connection.slave-type:                  team
connection.autoconnect-slaves:          -1 (default)
connection.secondaries:                 
connection.gateway-ping-timeout:        0
connection.metered:                     unknown
802-3-ethernet.port:                    --
802-3-ethernet.speed:                   0
802-3-ethernet.duplex:                  --
802-3-ethernet.auto-negotiate:          yes
802-3-ethernet.mac-address:             86:C7:46:48:82:77
802-3-ethernet.cloned-mac-address:      --
802-3-ethernet.mac-address-blacklist:   
802-3-ethernet.mtu:                     auto
802-3-ethernet.s390-subchannels:        
802-3-ethernet.s390-nettype:            --
802-3-ethernet.s390-options:            
802-3-ethernet.wake-on-lan:             1 (default)
802-3-ethernet.wake-on-lan-password:    --
team-port.config:                       {
    "link_watch": {
        "name": "ethtool"
    }
}
GENERAL.NAME:                           eth7
GENERAL.UUID:                           3d30dda3-eaa9-4cf4-a84a-2a7b9f5be050
GENERAL.DEVICES:                        eth7
GENERAL.STATE:                          activated
GENERAL.DEFAULT:                        no
GENERAL.DEFAULT6:                       no
GENERAL.VPN:                            no
GENERAL.ZONE:                           --
GENERAL.DBUS-PATH:                      /org/freedesktop/NetworkManager/ActiveConnection/3
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/Settings/16
GENERAL.SPEC-OBJECT:                    /
GENERAL.MASTER-PATH:                    /org/freedesktop/NetworkManager/Devices/1
[root@wlan-r2s22 control-center]# nmcli connection show te
team             team-slave-eth7  team-slave-eth8  testeth0         testeth1         testeth10        testeth2         testeth3         testeth4         testeth5         testeth6         testeth7         testeth8         testeth9
[root@wlan-r2s22 control-center]# nmcli connection show team-slave-eth7
connection.id:                          team-slave-eth7
connection.uuid:                        91716c27-1b94-4004-af33-c1ccc1560799
connection.interface-name:              eth7
connection.type:                        802-3-ethernet
connection.autoconnect:                 yes
connection.autoconnect-priority:        0
connection.timestamp:                   1456143088
connection.read-only:                   no
connection.permissions:                 
connection.zone:                        --
connection.master:                      nm-team
connection.slave-type:                  team
connection.autoconnect-slaves:          -1 (default)
connection.secondaries:                 
connection.gateway-ping-timeout:        0
connection.metered:                     unknown
802-3-ethernet.port:                    --
802-3-ethernet.speed:                   0
802-3-ethernet.duplex:                  --
802-3-ethernet.auto-negotiate:          yes
802-3-ethernet.mac-address:             --
802-3-ethernet.cloned-mac-address:      --
802-3-ethernet.mac-address-blacklist:   
802-3-ethernet.mtu:                     auto
802-3-ethernet.s390-subchannels:        
802-3-ethernet.s390-nettype:            --
802-3-ethernet.s390-options:            
802-3-ethernet.wake-on-lan:             1 (default)
802-3-ethernet.wake-on-lan-password:    --
team-port.config:                       --
Comment 1 Thomas Haller 2016-02-22 07:42:57 EST
Could be a dupe of bug 1294728
Comment 2 Beniamino Galvani 2016-04-13 05:03:38 EDT
(In reply to Thomas Haller from comment #1)
> Could be a dupe of bug 1294728

Yes, it is (this one is specifically about team slaves, while 1294728 is about team master, but they're really the same issue caused by mismatching JSON configuration after restart).

*** This bug has been marked as a duplicate of bug 1294728 ***

Note You need to log in before you can comment on or make changes to this bug.