Bug 1310642 - Provide more details in the Events/Tasks tab message when importing an image as template from an external provider
Provide more details in the Events/Tasks tab message when importing an image ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Idan Shaby
Elad
:
Depends On: 1302562
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 07:22 EST by Idan Shaby
Modified: 2016-07-05 04:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302562
Environment:
Last Closed: 2016-07-05 04:03:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
rule-engine: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53836 master MERGED backend: add AuditLogTypes to ImportRepoImageCommand 2016-02-23 11:50 EST

  None (edit)
Description Idan Shaby 2016-02-22 07:22:09 EST
This BZ is used for tracking the Events and Tasks message issue described in BZ 1302562.


+++ This bug was initially created as a clone of Bug #1302562 +++

Description of problem:
When importing image from external provider (for example from glance),

- There is no notification, like when importing from export domain, the import can be tracked in the event tab.

- when marking Import as template check box,
there is no indication in the events indicating it will be imported as template.
Event log:
Jan 28, 2016 7:49:52 AM
User admin@internal successfully imported image GlanceDisk-0b545df to domain data1.
Jan 28, 2016 7:49:52 AM
Template GlanceTemplate-82bd975 was created successfully.
Jan 28, 2016 7:49:17 AM
User admin@internal importing image GlanceDisk-0b545df to domain data1.


Version-Release number of selected component (if applicable):
rhevm 3.6.2-10

How reproducible:
always
Comment 1 Red Hat Bugzilla Rules Engine 2016-02-22 07:22:10 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 2 Red Hat Bugzilla Rules Engine 2016-02-22 07:22:34 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 3 Red Hat Bugzilla Rules Engine 2016-02-22 07:25:19 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Elad 2016-04-07 05:37:01 EDT
When importing an image as template from Glance repository, the following event is presented in the events log:

User admin@internal successfully imported image GlanceDisk-8a240e1 as template <UNKNOWN> to domain nfs2.

The template name is presented as <UNKNOWN> instead of the actual name which was specified in the import prompt. Opened a bug for that: Bug 1324780

Verified using:
ovirt-engine-4.0.0-0.0.master.20160406161747.gita4ecba2.el7.centos.noarch
ovirt-engine-webadmin-portal-4.0.0-0.0.master.20160406161747.gita4ecba2.el7.centos.noarch
Comment 5 Sandro Bonazzola 2016-07-05 04:03:15 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.