Bug 1310658 - Can't login any more to F22 with kernel 4.3.4-200
Can't login any more to F22 with kernel 4.3.4-200
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 07:42 EST by Roland Dirlewanger
Modified: 2016-05-23 07:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-23 07:19:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Dirlewanger 2016-02-22 07:42:01 EST
Description of problem:

Since I installed the last update of Fedora 22 on a Dell R620 or R610 server, it is not possible to login to the server, neither on the console nor with SSH.

SElinux is disabled on both servers


Version-Release number of selected component (if applicable):
kernel 4.3.4-200.fc22.x86_64


How reproducible:


Steps to Reproduce:
1. Boot Fedora 22 with kernel version 4.3.4 on a Dell R610 or R610 server without any window manager
2. Try to login on the console
3. Try to login with SSH

Actual results:
No login banner appears on the console : it just displays the "f" logo on a black screen. Connecting to the server with SSH blocks forever.

The problem does not show up when booting with previous the kernel (4.2.8-200).

Expected results:
Getting a login banner on the console
Getting a shell prompt when connecting to the server using SSH.


Additional info:

What I could observe :
- most (all ?) services are started on the server but there is no way to log on to it
- the command "ssh root@server bash" gives a shell without a prompt nor job control but helps to investigate further
- the command "ps ax | grep systemd" displays the following (note the D flag) :
  root         1  0.3  0.0  44156  5896 ?        Ds   13:15   0:02 /usr/lib/systemd/systemd --switched-root --system --deserialize 21
- systemctl seems to be broken. Trying to restart any service leads to this :
  systemctl restart httpd
  Failed to restart httpd.service: Connection timed out
- there's no way to reboot :
  reboot
  Failed to start reboot.target: Connection timed out
Comment 1 Roland Dirlewanger 2016-05-23 07:19:11 EDT
The problem disappeared on both servers after the kernel was upgraded to 4.4.9.

Note You need to log in before you can comment on or make changes to this bug.