Bug 1310687 - Differentiate between no proxies found and all proxies found are not available
Differentiate between no proxies found and all proxies found are not available
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Remote Execution (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Katello Bug Bin
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 09:16 EST by aruzicka
Modified: 2016-07-27 05:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:23:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13263 None None None 2016-04-22 11:00 EDT

  None (edit)
Description aruzicka 2016-02-22 09:16:16 EST
The proxy load balancer removes proxies that are down, which results in the same error message as if there were no proxies at all.  We should either tell the user a different error message, or include that info in the existing one.
Comment 1 aruzicka 2016-02-22 09:16:27 EST
Created from redmine issue http://projects.theforeman.org/issues/13263
Comment 3 Bryan Kearney 2016-02-24 12:07:49 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13263 has been closed
Comment 5 jcallaha 2016-04-21 16:29:30 EDT
Verified in Satellite 6.2 Beta Snap 9. You are now told when a proxy is down as well as when a proxy is not configured.
Comment 7 errata-xmlrpc 2016-07-27 05:23:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.