Bug 1310707 - [vdsm] Template creation after live snapshot merge on block storage fails with "low level Image copy failed"
[vdsm] Template creation after live snapshot merge on block storage fails wit...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.21
x86_64 Unspecified
unspecified Severity high (vote)
: ovirt-3.6.3
: 4.17.23
Assigned To: Ala Hino
Elad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 09:52 EST by Elad
Modified: 2016-03-10 07:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 07:48:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: planning_ack+
amureini: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)
/var/log/ from hypervisor and engine.log (1.30 MB, application/x-gzip)
2016-02-22 09:52 EST, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53883 None None None 2016-02-29 06:09 EST

  None (edit)
Description Elad 2016-02-22 09:52:35 EST
Created attachment 1129333 [details]
/var/log/ from hypervisor and engine.log

Description of problem:
On block storage: After a live snapshot merge tried to create a template from the VM. Template creation failed with:
"CopyImageError: low level Image copy failed"

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.2 (Maipo)
vdsm-4.17.21-0.el7ev.noarch
libvirt-daemon-1.2.17-13.el7_2.3.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.7.x86_64
sanlock-3.2.4-2.el7_2.x86_64
python-2.7.5-34.el7.x86_64

rhevm-3.6.3.2-0.1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a VM with 1 preallocated disk resides on iSCSI 
2. Create a snapshot
3. Start the VM and delete the snapshot
4. Stop the VM 
5. Create a template from the VM

Actual results:
During live snapshot merge I got this error message:

jsonrpc.Executor/4::ERROR::2016-02-22 16:26:22,738::dispatcher::76::Storage.Dispatcher::(wrapper) {'status': {'message': "Volume does not exist: (u'f991e88f-482c-4dc4-af47-7b2456404e13',)", 'code': 201}}


Template creation failure:

d8859e56-d899-4133-866e-68e87177c5a5::ERROR::2016-02-22 16:28:01,658::task::866::Storage.TaskManager.Task::(_setError) Task=`d8859e56-d899-4133-866e-68e87177c5a5`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 873, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/storage/task.py", line 332, in run
    return self.cmd(*self.argslist, **self.argsdict)
  File "/usr/share/vdsm/storage/securable.py", line 77, in wrapper
    return method(self, *args, **kwargs)
  File "/usr/share/vdsm/storage/sp.py", line 1570, in copyImage
    postZero, force)
  File "/usr/share/vdsm/storage/image.py", line 866, in copyCollapsed
    raise se.CopyImageError(str(e))
CopyImageError: low level Image copy failed: ("ecode=1, stdout=[], stderr=['qemu-img: /rhev/data-center/mnt/blockSD/ac6d8268-86f8-42dd-9a68-96b7305303ac/images/53c9e1e9-ee7c-4e51-94e9-02125a000949/bc0ff7ce-183f-4e
59-8429-509d869b4a41: error while converting raw: Device is too small'], message=None",)


Tested on NFS, was not able to reproduce.

Expected results:
Template creation should succeed.

Additional info:
/var/log/ from hypervisor and engine.log
Comment 1 Allon Mureinik 2016-02-23 07:37:55 EST
Ala/Adam, this looks like the same issue as bug 1301709. Please either confirm (and reset the target milestone to 3.6.3 and move the bug to MODIFIED) or issue a fix for 3.6.5.
Comment 2 Ala Hino 2016-02-29 06:09:40 EST
Was able to reproduce without the fix and was able to verify that issue is fixed with the fix. Changing target milestone to 3.6.3 and Moving to MODIFIED.
Comment 3 Elad 2016-03-03 04:07:36 EST
Template creation after live merge on a block storage works as expected.

Verified according to the steps described in the description using:
vdsm-4.17.23-0.el7ev.noarch
rhevm-3.6.3.4-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.