Bug 1310715 - [UI][setupNetworks dialog] - NIC and network panel tooltips are not updated immediately
[UI][setupNetworks dialog] - NIC and network panel tooltips are not updated i...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.3.2
x86_64 Linux
low Severity medium (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Ales Musil
Michael Burman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 10:07 EST by Michael Burman
Modified: 2017-12-20 05:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:48:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: ovirt‑4.3+


Attachments (Terms of Use)
New records with all flows (7.76 MB, application/x-gzip)
2017-10-29 04:09 EDT, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 82760 master MERGED webadmin: Fix NIC and Network tooltips are not updated immediately 2017-10-26 03:52 EDT
oVirt gerrit 83372 master MERGED webadmin: Add check if bond is updated or created 2017-10-30 09:40 EDT

  None (edit)
Description Michael Burman 2016-02-22 10:07:56 EST
Description of problem:
[setupNetworks dialog] - NIC and network panel tooltips are not updated immediately.

When making a change on the NIC panel, for example change bond mode, the tooltip will contain the old bond mode. The tooltip will be updated only when approving operation or another update that will affect the nic panel, like creating bond, breaking bond, adding slave to bond.. 

The same behavior for the Network panel. Currently today we don't display any network property on the network's tooltip that can be changed via the edit network dialog, but when BZ 1270570 and 1270569 will be fixed, same behavior will be for the network panel.

So the fix should be done for both panels, nic+network. 

Version-Release number of selected component (if applicable):
3.6.3.2-0.1.el6

How reproducible:
100

Steps to Reproduce:
1. Create bond mode 4(don't approve operation)
2. Change the bond mode to mode 1(don't approve operation)
3. Add additional slave to the bond(don't approve operation

Actual results:
1- bond mode=4
2- bond mode=4
3- bond mode=1

Expected results:
1- bond mode=4
2- bond mode=1
3- bond mode=1
Comment 1 Dan Kenigsberg 2016-02-24 04:29:05 EST
Alona, it's quite odd that only the first change to the network attachment has been copied to the tooltip, but further changes did not. Is this only a GUI glitch or somehting more sinister?
Comment 2 Alona Kaplan 2016-02-24 04:51:14 EST
Yes, I also was surprised when discovered this bug.
It is a ui only bug, the problem is the tooltip is being built once when the panel of the network/nic is created. So updates that don't cause the panel to be recreated, are not affected in the tooltip.
Comment 3 Sandro Bonazzola 2016-05-02 05:52:14 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 4 Yaniv Lavi 2016-05-23 09:15:19 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 5 Yaniv Lavi 2016-05-23 09:20:29 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 6 Michael Burman 2017-10-29 04:08:09 EDT
Hi Ales,

There a scenario that isn't fixed, the bond's tooltip doesn't updated immediately after already been created. 

1) Create bond mode=4 and approve operation
2) Update the bond with mode=1 and check tooltip

Result - the tooltip shows bond mode=4 and not 1

- On the newly bond creation flow, the tooltip updated immediately and this is fixed. 
- The network flow is working as expected on new attachment flow and on update after creation.

Attaching records with all flow( 3 PASS, 1 Failed)
Comment 7 Michael Burman 2017-10-29 04:09 EDT
Created attachment 1344975 [details]
New records with all flows
Comment 8 Michael Burman 2017-11-02 08:23:07 EDT
Verified on - 4.2.0-0.0.master.20171101152059.git8b85834.el7.centos
Comment 9 Sandro Bonazzola 2017-12-20 05:48:25 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.