Bug 1310716 - spacewalk-repo-sync doesn't work with parameter --latest'
spacewalk-repo-sync doesn't work with parameter --latest'
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
2.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiří Dostál
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2016-02-22 10:08 EST by Pavel Studeník
Modified: 2017-09-28 14:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 04:11:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2016-02-22 10:08:40 EST
Description of problem:
I tried to sync fedora's channel and when I run it with parameter --latest I received error.

Sync started: Mon Feb 22 09:47:33 2016
['/usr/bin/spacewalk-repo-sync', '--channel', 'fedora-23-x86_64', '--type', 'yum', '--latest']
Repo URL: http://download.eng.brq.redhat.com/pub/fedora/linux/releases/23/Everything/x86_64/os/
ERROR: 'NoneType' object has no attribute 'group'
Sync completed.
Total time: 0:01:03

But without param "--latest" it works.

Sync started: Mon Feb 22 09:58:28 2016
['/usr/bin/spacewalk-repo-sync', '--channel', 'fedora-23-x86_64', '--type', 'yum']
Repo URL: http://download.eng.brq.redhat.com/pub/fedora/linux/releases/23/Everything/x86_64/os/
Packages in repo:             46074
....

Version-Release number of selected component (if applicable):
spacewalk-backend-tools-2.4.23-1.el7.noarch

How reproducible:
always
Comment 1 Tomas Lestach 2016-02-22 11:51:05 EST
I believe this has been fixed already. Jiri, would you put here the right commit, please?
Comment 2 Jiří Dostál 2016-02-23 07:01:43 EST
This issue has been fixed by following pull request https://github.com/spacewalkproject/spacewalk/pull/347
Comment 3 Ramrajan 2016-03-03 14:28:05 EST
I am having the same issue syncing with my repository. I am super new with github and getting the patches?

How do i get the updated code in  to my server?
Comment 4 Tomáš Kašpárek 2016-06-16 04:11:44 EDT
Spacewalk 2.5 was released.
Comment 5 Eric Herget 2017-09-28 14:12:00 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.