Bug 131075 - MAKEDEV won't install while udev is active
MAKEDEV won't install while udev is active
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: MAKEDEV (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks: 118861 FC3Blocker
  Show dependency treegraph
 
Reported: 2004-08-27 06:15 EDT by Michael Young
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.9.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 11:43:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2004-08-27 06:15:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6)
Gecko/20040116

Description of problem:
You can't install or upgrade MAKEDEV (3.9-1) while udev is active, as
the preinstall script stops you with an error about devfs. If MAKEDEV
and udev are supposed to coexist this is clearly a problem.
Comment 1 Harald Hoyer 2004-08-30 07:32:26 EDT
one could:

%pre
mount --move /dev /tmp/dev

and after updating /dev

%post
mount --move /tmp/dev /dev
Comment 2 Nalin Dahyabhai 2004-08-30 12:17:09 EDT
That introduces a race condition if permissions as set by udev don't
match what the dev package contains -- I'd rather not go there.
Comment 3 Nalin Dahyabhai 2004-08-31 11:43:28 EDT
Supposedly udev and/or initscripts will conspire together to make sure
that /dev/MAKEDEV is present, so it can be removed from the package. 
Because the MAKEDEV package no longer stores anything in /dev, the
%pre scriptlet can be removed as well.

Note You need to log in before you can comment on or make changes to this bug.