Bug 1310755 - glusterd: coverity warning in glusterd-snapshot-utils.c copy_nfs_ganesha_file()
glusterd: coverity warning in glusterd-snapshot-utils.c copy_nfs_ganesha_file()
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Reopened, Triaged
Depends On:
Blocks: 1315009
  Show dependency treegraph
 
Reported: 2016-02-22 10:42 EST by Kaleb KEITHLEY
Modified: 2016-06-16 09:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1315009 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:58:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2016-02-22 10:42:32 EST
Description of problem:

coverity warning

Version-Release number of selected component (if applicable):

mainline, 3.7.x

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:



> ** CID 1351702:  Code maintainability issues  (UNUSED_VALUE)
> /data/workspace/gluster/glusterfs/xlators/mgmt/glusterd/src/glusterd-snapshot-utils.c: 3695 in glusterd_copy_nfs_ganesha_file()
>
>
> ________________________________________________________________________________________________________
> *** CID 1351702:  Code maintainability issues  (UNUSED_VALUE)
> /data/workspace/gluster/glusterfs/xlators/mgmt/glusterd/src/glusterd-snapshot-utils.c: 3695 in glusterd_copy_nfs_ganesha_file()
> 3689     
> 3690             GF_VALIDATE_OR_GOTO (this->name, src_vol, out);
> 3691             GF_VALIDATE_OR_GOTO (this->name, dest_vol, out);
> 3692     
> 3693             if (src_vol->is_snap_volume) {
> 3694                     GLUSTERD_GET_SNAP_DIR (snap_dir, src_vol->snapshot, priv);
>>>>     CID 1351702:  Code maintainability issues  (UNUSED_VALUE)
>>>>     Assigning value from "snprintf(src_path, 4096UL, "%s/export.%s.conf", snap_dir, src_vol->snapshot->snapname)" to "ret" here, but that stored value is overwritten before it can be used.
> 3695                     ret = snprintf (src_path, sizeof (src_path),
> 3696                                     "%s/export.%s.conf", snap_dir,
> 3697                                     src_vol->snapshot->snapname);
> 3698             } else {
> 3699                     ret = snprintf (src_path, sizeof (src_path),
> 3700                                     "%s/export.%s.conf", GANESHA_EXPORT_DIRECTORY,

...
Comment 1 Vijay Bellur 2016-02-22 11:06:38 EST
REVIEW: http://review.gluster.org/13486 (glusterd: coverity warning in glusted_copy_nfs_ganesha_file()) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Vijay Bellur 2016-02-22 13:14:37 EST
REVIEW: http://review.gluster.org/13486 (glusterd: coverity warning in glusted_copy_nfs_ganesha_file()) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 3 Vijay Bellur 2016-02-23 11:45:03 EST
COMMIT: http://review.gluster.org/13486 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit ec6eb8200e41dadc623fd2341a3c5cf8cc71dec7
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Mon Feb 22 11:02:31 2016 -0500

    glusterd: coverity warning in glusted_copy_nfs_ganesha_file()
    
    fix unused return value from snprintf.
    
    Also minor cleanup, including safe handling of truncated output by
    snprintf.
    
    Change-Id: Ibec8c7e6cc4ef07b6535d01a0719359fa3ef8030
    BUG: 1310755
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13486
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:58:25 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.