Bug 1310777 - Failed to update overcloud without overcloud-resource-registry-puppet.yaml file
Failed to update overcloud without overcloud-resource-registry-puppet.yaml file
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
All All
unspecified Severity medium
: ---
: 10.0 (Newton)
Assigned To: Angus Thomas
Arik Chernetsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 11:09 EST by Guillaume Chenuet
Modified: 2016-10-11 09:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-11 09:38:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guillaume Chenuet 2016-02-22 11:09:22 EST
Description of problem:

For an update between osp-d 7.2 and 7.3, I missed to add overcloud-resource-registry-puppet.yaml file in my update line.

Update failed with error:
resources.Networks: resources.StorageNetwork: Conflict: resources.StorageSubnet: Unable to complete operation on subnet faa5d940-00d9-47a4-b6f1-31346dcced3b. One or more ports have an IP allocation from this subnet.

It's also failed with others networks (InternalApi, External, etc)

When I added this file and re-launched my update, Heat try to continue to create subnets. 
It was too late...

I had to delete the stack, recreate it and upgrade it !

If I'm correct, without this file, Heat try to (re)create the stack (with networks, subnets, etc).

Version-Release number of selected component (if applicable):
openstack-neutron-common-2015.1.2-9.el7ost.noarch
openstack-tripleo-0.0.7-0.1.1664e566.el7ost.noarch
openstack-neutron-2015.1.2-9.el7ost.noarch
openstack-swift-account-2.3.0-4.el7ost.noarch
openstack-nova-cert-2015.1.2-18.el7ost.noarch
openstack-tuskar-ui-0.4.0-5.el7ost.noarch
openstack-ironic-common-2015.1.2-2.el7ost.noarch
openstack-dashboard-2015.1.2-4.el7ost.noarch
openstack-utils-2014.2-1.el7ost.noarch
openstack-tripleo-common-0.0.1.dev6-6.git49b57eb.el7ost.noarch
openstack-nova-console-2015.1.2-18.el7ost.noarch
openstack-heat-api-cloudwatch-2015.1.2-9.el7ost.noarch
openstack-ironic-discoverd-1.1.0-8.el7ost.noarch
openstack-tempest-kilo-20151020.1.el7ost.noarch
openstack-ceilometer-alarm-2015.1.2-1.el7ost.noarch
openstack-ironic-conductor-2015.1.2-2.el7ost.noarch
openstack-swift-2.3.0-4.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-121.el7ost.noarch
openstack-tripleo-image-elements-0.9.6-10.el7ost.noarch
openstack-nova-novncproxy-2015.1.2-18.el7ost.noarch
openstack-keystone-2015.1.2-2.el7ost.noarch
openstack-heat-templates-0-0.8.20150605git.el7ost.noarch
openstack-tuskar-ui-extras-0.0.4-2.el7ost.noarch
openstack-ceilometer-notification-2015.1.2-1.el7ost.noarch
openstack-glance-2015.1.2-1.el7ost.noarch
openstack-ceilometer-collector-2015.1.2-1.el7ost.noarch
openstack-neutron-ml2-2015.1.2-9.el7ost.noarch
openstack-swift-proxy-2.3.0-4.el7ost.noarch
openstack-nova-api-2015.1.2-18.el7ost.noarch
openstack-heat-api-cfn-2015.1.2-9.el7ost.noarch
openstack-heat-api-2015.1.2-9.el7ost.noarch
openstack-puppet-modules-2015.1.8-51.el7ost.noarch
openstack-swift-plugin-swift3-1.7-3.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1-5.el7ost.noarch
openstack-nova-conductor-2015.1.2-18.el7ost.noarch
openstack-tuskar-0.4.18-5.el7ost.noarch
openstack-ceilometer-common-2015.1.2-1.el7ost.noarch
openstack-ceilometer-api-2015.1.2-1.el7ost.noarch
openstack-ironic-api-2015.1.2-2.el7ost.noarch
openstack-neutron-openvswitch-2015.1.2-9.el7ost.noarch
openstack-swift-container-2.3.0-4.el7ost.noarch
openstack-nova-scheduler-2015.1.2-18.el7ost.noarch
openstack-dashboard-theme-2015.1.2-4.el7ost.noarch
openstack-selinux-0.6.46-1.el7ost.noarch
openstack-nova-common-2015.1.2-18.el7ost.noarch
openstack-nova-compute-2015.1.2-18.el7ost.noarch
openstack-swift-object-2.3.0-4.el7ost.noarch
openstack-heat-engine-2015.1.2-9.el7ost.noarch
openstack-ceilometer-central-2015.1.2-1.el7ost.noarch
openstack-heat-common-2015.1.2-9.el7ost.noarch

How reproducible:

Deploy a 7.2 OSP ans upgrade it without overcloud-resource-registry-puppet.yaml file.

Steps to Reproduce:
1. Deploy OSP in 7.2
2. Upgrade it to 7.3 without overcloud-resource-registry-puppet.yaml file.

Actual results:

Heat update failed because Heat try to recreate subnets.

Expected results:

It should be good to add overcloud-resource-registry-puppet.yaml file by default for the 'openstack overcloud update stack overcloud' command.

And/Or explain that is mandatory to have this file to succeed an upgrade.


Additional info:
Comment 2 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 3 Jaromir Coufal 2016-10-11 09:38:37 EDT
All the files are required to succeed in updates. Closing the bug, in following releases we simplified commands.

Note You need to log in before you can comment on or make changes to this bug.