Bug 1310788 - getservbyname("nfsrdma", "tcp") returns wrong values
getservbyname("nfsrdma", "tcp") returns wrong values
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glibc (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carlos O'Donell
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 11:22 EST by Steve Dickson
Modified: 2016-02-22 12:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 12:04:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2016-02-22 11:22:22 EST
Description of problem:
getservbyname("nfsrdma", "tcp") should return
   name 'nfsrdma' port 20049 proto 'tcp'

since that is one of the 3 nfsrdma entries in /etc/services 

$ grep nfsrdma /etc/services 
nfsrdma         20049/tcp               # Network File System (NFS) over RDMA
nfsrdma         20049/udp               # Network File System (NFS) over RDMA
nfsrdma         20049/sctp              # Network File System (NFS) over RDMA

but these are the values being returned 
   name 'nfsrdma' port 20814 proto 'tcp' 

and you will note port 20814 does not exist 
in /etc/sevices 



Version-Release number of selected component (if applicable):
glibc-2.17-105.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Use the following reproducer 
#include <stdio.h>
#include <netdb.h>

main()
{
	struct servent *sv = getservbyname("nfsrdma", "tcp");

	if (sv)
		printf("name '%s' port %d proto '%s'\n", 
		sv->s_name, sv->s_port, sv->s_proto);
}
Comment 2 Florian Weimer 2016-02-22 12:04:38 EST
The returned port number is in network byte order.  Use this instead:

#include <stdio.h>
#include <netdb.h>

main()
{
	struct servent *sv = getservbyname("nfsrdma", "tcp");

	if (sv)
		printf("name '%s' port %d proto '%s'\n", 
		sv->s_name, ntohs(sv->s_port), sv->s_proto);
}

It's unfortunate the two numbers are so close together, otherwise it would be easier to spot the mistake.
Comment 3 Steve Dickson 2016-02-22 12:54:54 EST
(In reply to Florian Weimer from comment #2)
> The returned port number is in network byte order.  Use this instead:
> 
> #include <stdio.h>
> #include <netdb.h>
> 
> main()
> {
> 	struct servent *sv = getservbyname("nfsrdma", "tcp");
> 
> 	if (sv)
> 		printf("name '%s' port %d proto '%s'\n", 
> 		sv->s_name, ntohs(sv->s_port), sv->s_proto);
> }
> 
> It's unfortunate the two numbers are so close together, otherwise it would
> be easier to spot the mistake.
Ah... Perfect... Thanks you!!!

Note You need to log in before you can comment on or make changes to this bug.