Bug 131079 - max connections reached
max connections reached
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
powerpc Linux
medium Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-27 07:05 EDT by jeroen
Modified: 2013-03-13 00:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 16:43:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jeroen 2004-08-27 07:05:54 EDT
dbus_bindings.DBusException: Connection ":1.16" is not allowed to add
more match rules (increase limits in configuration file if required)

This exceptions happens quite fast when you're playing around with
hal-device-manager and connecting & disconnecting devices. Everytime
you restart hal-device-manager, the connection number increases.
Restarting message-bus or haldaemon has no effect.

This is with dbus-0.22-4 and hal-0.2.97.cvs20040823-3.

I looked around in /etc/dbus-1/*.conf, but i didn't see anything that
would limit the number of connections.
Comment 1 David Zeuthen 2004-08-31 07:40:12 EDT
I can confirm that the "number of match rules" limit is not
configurable like other limits in the system. However, IMHO it's not
super high priority to fix it because I'm not sure if we will ship
hal-device-manager at all. 

Reassigning to dbus.

Thanks,
David
Comment 2 John (J5) Palmieri 2004-09-16 16:43:53 EDT
This bug should go upstream.

Note You need to log in before you can comment on or make changes to this bug.