Bug 1310790 - Management network is out of sync with host once refreshing caps on host with 3.5 vdsm version in cluster 3.6
Management network is out of sync with host once refreshing caps on host with...
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.3.2
x86_64 Linux
low Severity medium (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: Dan Kenigsberg
Michael Burman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 11:29 EST by Michael Burman
Modified: 2016-12-05 01:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-05 01:19:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
danken: ovirt‑4.1?
mburman: planning_ack?
mburman: devel_ack?
mburman: testing_ack?


Attachments (Terms of Use)
Logs (832.07 KB, application/x-gzip)
2016-02-22 11:29 EST, Michael Burman
no flags Details

  None (edit)
Description Michael Burman 2016-02-22 11:29:59 EST
Created attachment 1129403 [details]
Logs

Description of problem:
Management network is out of sync with host once refreshing caps on host with 3.5 vdsm version in cluster 3.6.

If trying to refresh caps on host with 3.5 vdsm version in a 3.6 cluster, it will cause to the management network to be reported as out-of-sync with the host and a change in bootproto will be recognized. on host will reported static ip, while the actual bootproto is dhcp. This is because the 3.6 cluster expecting to some arguments/fields that don't exist in vdsm 3.5 

The following errors will be shown:
"Host orchid-vds2.qa.lab.tlv.redhat.com is compatible with versions (3.4,3.5) and cannot join Cluster Test_cluster which is set to version 3.6."

"Host orchid-vds2.qa.lab.tlv.redhat.com's following network(s) are not synchronized with their Logical Network configuration: ovirtmgmt."

"VDSM orchid-vds2.qa.lab.tlv.redhat.com command failed: The method does not exist / is not available."

When trying to activate the host it moves to Non-operational, but from time to time host stuck in connecting state. 

Version-Release number of selected component (if applicable):
3.6.3.2-0.1.el6
vdsm-4.16.34-2.el7ev

How reproducible:
100

Steps to Reproduce:
1. Add host 3.5 to cluster 3.5 in engine 3.6
2. Set host to maintenance and move to 3.6 cluster
3. Refresh caps on host or try to activate

Actual results:
management network reported as out of sync

Expected results:
management network should in sync with host, no matter if the host is compatible with the cluster version or not.
Comment 1 Dan Kenigsberg 2016-02-24 04:35:58 EST
This can probably be solved if we call getVdsCaps prior to going Up, but consume ONLY the clusterLevel element end its friends.

Note You need to log in before you can comment on or make changes to this bug.