Bug 1310803 - [RFE] Add support for Nuage to puppet-neutron in 7.3
[RFE] Add support for Nuage to puppet-neutron in 7.3
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
x86_64 Unspecified
medium Severity urgent
: async
: 7.0 (Kilo)
Assigned To: Jason Guiditta
nlevinki
: FutureFeature, ZStream
: 1323846 (view as bug list)
Depends On:
Blocks: 1258485
  Show dependency treegraph
 
Reported: 2016-02-22 12:04 EST by lokesh.jain
Modified: 2016-09-22 12:29 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-22 12:29:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comparison between 7.3 and 8.0 versions (2.31 KB, text/plain)
2016-02-22 12:04 EST, lokesh.jain
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 298792 None None None 2016-04-05 12:31 EDT

  None (edit)
Description lokesh.jain 2016-02-22 12:04:56 EST
Created attachment 1129411 [details]
Comparison between 7.3 and 8.0 versions

Description of problem:

Code to enable support for Nuage has been merged upstream. The code that was pulled-in is for 8.0 and we would need to pull in 7.3 version.

We need only the following two files from https://review.openstack.org/#/c/214798/

1. lib/puppet/provider/neutron_plugin_nuage/ini_setting.rb (patch set 8)
2. lib/puppet/type/neutron_plugin_nuage.rb (patch set 8)

Attaching the 7.3 and 8.0 version files for reference.
Comment 2 Jason Guiditta 2016-02-26 13:03:13 EST
So, after digging around a bit, I now see that the referenced patch was added to puppet-neutron on master before liberty branched, meaning the patch (and a subsequent fix[1]) are on the current upstream master and stable/liberty.  To clarify the request here, you are saying basically everything in the master/liberty patch is unneeded _except_ for the two referenced files, is that correct?  If so, I think the best path here, so this gets at least a bit of proper testing for kilo, is for you (or Ramkumar, who seems to have done the original work) to propose a patch upstream to the stable/kilo branch.  I would think this should include at least the relevant spec (perhaps updated) from the original patch[2].  I may be able to attempt to do the same thing later today, but I am not that familiar with nuage, so it would make more sense for someone who knows it to submit the patch, which I can then backport to OSP7 (and remove the previous two, as shown in [1]).  Does that sound reasonable?

[1] https://review.openstack.org/#/q/project:openstack/puppet-neutron+nuage
[2] https://review.openstack.org/#/c/214798/23/spec/unit/provider/neutron_plugin_nuage/ini_setting_spec.rb
Comment 3 Brad P. Crochet 2016-03-09 10:26:32 EST
Has there been any progress on the backport, Lokesh?
Comment 4 lokesh.jain 2016-03-09 13:24:23 EST
We are working on verifying the changes with the latest OSP-D 7.3 build. After Nuage integration verification is done, will start working on up-streaming these changes.
Comment 5 lokesh.jain 2016-04-05 12:31:56 EDT
Added Openstack gerrit review ID 298792, that has the backported changes to stable/kilo. Please update OSP7.3 to include the changes.
Comment 6 lokesh.jain 2016-04-05 12:32:08 EDT
*** Bug 1323846 has been marked as a duplicate of this bug. ***
Comment 8 Jason Guiditta 2016-05-03 09:18:56 EDT
Need acks to get this into osp 7.x
Comment 14 Scott Drennan 2016-09-22 12:29:00 EDT
At this point, we have a workaround to manually update the required packages, and given OSPD 7.x is not planned for further releases, let's just close this out.

Note You need to log in before you can comment on or make changes to this bug.