Bug 1310804 - [RFE] Override instance type on VmPools in Python-SDK
[RFE] Override instance type on VmPools in Python-SDK
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
3.6.2
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.2
: 4.0.2.1
Assigned To: Tomas Jelinek
sefi litmanovich
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 12:09 EST by nicolas
Modified: 2016-08-22 21:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The instance type field was missing in the REST API virtual machine pool resource. This update adds the ability to pick one when creating the virtual machine pool, and to report the currently configured instance type.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-12 10:27:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.z+
slitmano: testing_plan_complete?
mgoldboi: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 55936 master MERGED restapi: Added instance type to the pool creation 2016-04-12 11:10 EDT
oVirt gerrit 55937 master MERGED restapi: added instance type to add pool 2016-04-14 04:08 EDT
oVirt gerrit 60092 master MERGED restapi: instance type not reported for pools 2016-07-11 02:59 EDT
oVirt gerrit 60458 ovirt-engine-4.0 MERGED restapi: instance type not reported for pools 2016-07-11 12:10 EDT

  None (edit)
Description nicolas 2016-02-22 12:09:26 EST
Description of problem:

When creating VM Pools via the webadmin, we're allowed to pick an instance type (Small, Medium, ...) that will override hardware resources that have been set in the template on which is based the pool.

In Python-SDK there seems not to be a parameter that allows specifying an instance_type on params.VmPool objects.

Would it be difficult to implement this?
Comment 1 Juan Hernández 2016-02-22 12:19:06 EST
This isn't possible in the Python SDK because it isn't implemented in the server side of the API. When it is eventually implemented, it will be automatically supported by the SDK, as its code is generated automatically from the specification of the API.
Comment 2 Red Hat Bugzilla Rules Engine 2016-04-06 08:12:44 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Tomas Jelinek 2016-04-13 02:38:33 EDT
not urgent RFE - not a 3.6.6 material. Pushing to 4.0
Comment 7 sefi litmanovich 2016-06-28 07:55:43 EDT
Failed to verify with rhevm-4.0.0.6-0.1.el7ev.noarch - instance type reference doesn't exist in vm pool's xsd. It isn't possible to create a vm pool with instance type via API and also to see the instance type of an existing vm pool created in webadmin.
Comment 8 Red Hat Bugzilla Rules Engine 2016-06-28 07:55:50 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 9 Red Hat Bugzilla Rules Engine 2016-06-28 09:30:31 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 10 Red Hat Bugzilla Rules Engine 2016-06-28 09:31:12 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 11 Red Hat Bugzilla Rules Engine 2016-06-28 09:31:39 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 12 sefi litmanovich 2016-06-29 11:09:38 EDT
UPDATE - Had a mistake while trying to verify the RFE, xml had a typo.
With the correct xml the instance type is created properly but:
1. Instance_type reference doesn't exist in pool's xml.
2. Changing the instance type should be impossible and produce error, but I was able to call PUT and provide vm_pool with a different instance_type, the result was vm pool not actually changed the instance type, but no error was produced and RC was 200 - so another thing that should be fixed.
Comment 13 Tomas Jelinek 2016-07-12 01:47:08 EDT
Please note that the fix handles only the REST API part for 4.0 (e.g. the SDK may still be affected for 4.0 and will start working in 4.1).

The 2. from Comment 12 is not fixed - it is a cosmetic issue and will not be backported to 4.0. Please open a separate bug for it.
Comment 14 sefi litmanovich 2016-07-27 08:46:11 EDT
Verified with rhevm-4.0.2-0.1.rc.el7ev.noarch.
the cases attached to this bug from polarion.
Regarding editing the vm pool and changing instance type - PUT action succeeds but in fact the instance type doesn't change, which is ok, I will open a different bz in order to fail already on PUT call (as suggested in comment 13).

Verified also that vm pool's instance type is reachable in the new sdk for api v4: python-ovirt-engine-sdk4-4.0.0-0.5.a5.el7ev.x86_64

Note You need to log in before you can comment on or make changes to this bug.