Bug 1310807 - Utilize QoS to prevent excessive client side queueing of messages
Utilize QoS to prevent excessive client side queueing of messages
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-oslo-messaging (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ga
: 8.0 (Liberty)
Assigned To: John Eckersberg
Udi Shkalim
:
Depends On: 1295896
Blocks: 1302861 1302873
  Show dependency treegraph
 
Reported: 2016-02-22 12:12 EST by John Eckersberg
Modified: 2016-04-27 01:23 EDT (History)
11 users (show)

See Also:
Fixed In Version: python-oslo-messaging-2.5.0-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1295896
Environment:
Last Closed: 2016-04-07 17:30:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1531222 None None None 2016-02-22 12:12 EST
OpenStack gerrit 279834 None None None 2016-02-22 12:12 EST

  None (edit)
Comment 3 Udi Shkalim 2016-03-09 05:14:38 EST
Verified on:python-oslo-messaging-2.5.0-4.el7ost.noarch

Added rabbit_qos_prefetch_count=50 in nova.conf and neutron.conf under the rabbit section and restart the services.

[root@overcloud-controller-2 ~]# rabbitmqctl list_channels name prefetch_count  | grep 50
10.35.169.13:48413 -> 10.35.169.13:5672 (1)	50
10.35.169.13:48472 -> 10.35.169.13:5672 (1)	50
10.35.169.13:48475 -> 10.35.169.13:5672 (1)	50
10.35.169.13:48478 -> 10.35.169.13:5672 (1)	50
10.35.169.13:48479 -> 10.35.169.13:5672 (1)	50
10.35.169.13:48482 -> 10.35.169.13:5672 (1)	50
10.35.169.13:48484 -> 10.35.169.13:5672 (1)	50
10.35.169.13:48491 -> 10.35.169.13:5672 (1)	50
10.35.169.13:48669 -> 10.35.169.13:5672 (1)	50
10.35.169.13:48737 -> 10.35.169.13:5672 (1)	50
10.35.169.13:48836 -> 10.35.169.13:5672 (1)	50
10.35.169.13:54470 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54472 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54474 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54476 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54479 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54482 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54483 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54486 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54659 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54665 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54669 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54672 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54675 -> 10.35.169.15:5672 (1)	50
10.35.169.13:54747 -> 10.35.169.15:5672 (1)	50
10.35.169.13:56116 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56170 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56171 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56173 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56174 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56176 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56185 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56187 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56188 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56192 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56359 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56370 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56384 -> 10.35.169.14:5672 (1)	50
10.35.169.13:56528 -> 10.35.169.14:5672 (1)	50
Comment 4 errata-xmlrpc 2016-04-07 17:30:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.