Bug 1310826 - [rabbitmq-server] Stops running when memory is low
[rabbitmq-server] Stops running when memory is low
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rabbitmq-server (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Peter Lemenkov
Udi Shkalim
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 12:38 EST by Joe Talerico
Modified: 2017-01-06 10:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-06 07:15:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Talerico 2016-02-22 12:38:58 EST
Description of problem:
When the director node runs out of physical memory, RabbitMQ shuts itself down due to running out of memory. eck has traced it to here :

ERTS_ALC_INLINE
void *erts_alloc_fnf(ErtsAlcType_t type, Uint size)
{
    return (*erts_allctrs[ERTS_ALC_T2A(type)].alloc)(
        ERTS_ALC_T2N(type),
        erts_allctrs[ERTS_ALC_T2A(type)].extra,
        size);
}

Version-Release number of selected component (if applicable):
ospd72 (RHN) 

How reproducible:
100%

Steps to Reproduce:
1. OSPd w/ 8GB of RAM should cause this to happen with a small POC deployment

Actual results:
RabbitMQ-server stops

Expected results:
RabbitMQ-Server keep thumping
Comment 3 Peter Lemenkov 2017-01-06 07:15:43 EST
OOM will kill it anyway if the memory is low, and it's hard to handle it properly (both from technical, and from business logic PoVs).

The proper way to "fix" that is to either adjust number of messages pushed into / read from RabbitMQ (it's not up to the bus to decide what message to store and what to discard to prevent OOM), or increase total size of physical memory available.

I'm going to close this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.