Bug 1310840 - Removing gstreamer1-plugins-base pulls too many dependencies
Removing gstreamer1-plugins-base pulls too many dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
25
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 13:40 EST by srakitnican
Modified: 2016-07-27 08:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 08:28:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Created archive with dnf --debugdata switch. (2.04 MB, application/x-bzip)
2016-02-22 13:40 EST, srakitnican
no flags Details
debugdata (1.18 MB, application/x-xz)
2016-07-21 15:48 EDT, srakitnican
no flags Details

  None (edit)
Description srakitnican 2016-02-22 13:40:40 EST
Created attachment 1129460 [details]
Created archive with dnf --debugdata switch.

Description of problem: 

$ sudo dnf remove gstreamer1-plugins-base
Dependencies resolved.
=====================================================================================================================
 Package                                   Arch   Version                      Repository                       Size
=====================================================================================================================
Removing:
 anaconda                                  x86_64 23.19.10-1.fc23              @@commandline                     0  
 anaconda-gui                              x86_64 23.19.10-1.fc23              @@commandline                   1.3 M
 bijiben                                   x86_64 3.18.2-1.fc23                @updates                        1.4 M
 brasero-libs                              x86_64 3.12.1-3.fc23                @updates                        948 k
 cheese                                    x86_64 2:3.18.1-1.fc23              @@commandline                   409 k
 cheese-libs                               x86_64 2:3.18.1-1.fc23              @@commandline                   2.4 M
 clutter-gst2                              x86_64 2.0.16-2.fc23                @@commandline                   199 k
 clutter-gst3                              x86_64 3.0.14-2.fc23                @@commandline                   214 k
 control-center                            x86_64 1:3.18.2-1.fc23              @updates                         18 M
 cryptopp                                  x86_64 5.6.2-9.fc23                 @@commandline                   4.4 M
 dleyna-server                             x86_64 0.5.0-2.fc23                 @@commandline                   206 k
 empathy                                   x86_64 3.12.11-3.fc23               @updates                         14 M
 epiphany-runtime                          x86_64 1:3.18.3-1.fc23              @updates                        1.4 M
 evince-nautilus                           x86_64 3.18.2-3.fc23                @updates                         19 k
 evolution                                 x86_64 3.18.4-1.fc23                @updates                         43 M
 evolution-data-server                     x86_64 3.18.4-1.fc23                @updates                         14 M
 evolution-ews                             x86_64 3.18.4-1.fc23                @updates                        2.0 M
 evolution-help                            noarch 3.18.4-1.fc23                @updates                         10 M
 farstream02                               x86_64 0.2.7-2.fc23                 @@commandline                   710 k
 folks                                     x86_64 1:0.11.1-3.fc23              @@commandline                   2.5 M
 freerdp-libs                              x86_64 2:1.2.0-0.9.git.24a752a.fc23 @@commandline                   2.7 M
 fwupd                                     x86_64 0.5.4-1.fc23                 @updates                        323 k
 fwupdate-efi                              x86_64 0.5-3.fc23                   @updates                         64 k
 fwupdate-libs                             x86_64 0.5-3.fc23                   @updates                         31 k
 gdm                                       x86_64 1:3.18.2-2.fc23              @updates                        3.3 M
 gfbgraph                                  x86_64 0.2.3-1.fc23                 @@commandline                    92 k
 gimp                                      x86_64 2:2.8.16-1.fc23              @updates                         63 M
 gnome-boxes                               x86_64 3.18.1-1.fc23                @@commandline                   4.8 M
 gnome-classic-session                     noarch 3.18.3-1.fc23                @updates                        194 k
 gnome-contacts                            x86_64 3.18.1-1.fc23                @updates                        1.5 M
 gnome-documents                           x86_64 3.18.2-1.fc23                @updates                        1.9 M
 gnome-documents-libs                      x86_64 3.18.2-1.fc23                @updates                        1.2 M
 gnome-initial-setup                       x86_64 3.18.0-1.fc23                @@commandline                   2.1 M
 gnome-maps                                x86_64 3.18.2-1.fc23                @updates                        1.2 M
 gnome-online-accounts                     x86_64 3.18.3-1.fc23                @updates                        4.2 M
 gnome-online-miners                       x86_64 3.14.3-3.fc23                @@commandline                   341 k
 gnome-shell                               x86_64 3.18.3-1.fc23                @updates                        9.3 M
 gnome-shell-extension-alternate-tab       noarch 3.18.3-1.fc23                @updates                        9.4 k
 gnome-shell-extension-apps-menu           noarch 3.18.3-1.fc23                @updates                         26 k
 gnome-shell-extension-background-logo     noarch 3.18.0-1.fc23                @@commandline                    56 k
 gnome-shell-extension-common              noarch 3.18.3-1.fc23                @updates                        545 k
 gnome-shell-extension-launch-new-instance noarch 3.18.3-1.fc23                @updates                        4.9 k
 gnome-shell-extension-places-menu         noarch 3.18.3-1.fc23                @updates                         23 k
 gnome-shell-extension-window-list         noarch 3.18.3-1.fc23                @updates                         56 k
 gnome-software                            x86_64 3.18.3-1.fc23                @updates                        4.2 M
 grilo-plugins                             x86_64 0.2.17-1.fc23                @updates                        1.6 M
 gstreamer-plugins-espeak                  x86_64 0.4.0-7.fc23                 @@commandline                    59 k
 gstreamer1-libav                          x86_64 1.6.3-1.fc23                 @rpmfusion-free-updates-testing 650 k
 gstreamer1-plugins-bad-free               x86_64 1.6.3-1.fc23                 @updates                        5.6 M
 gstreamer1-plugins-base                   x86_64 1.6.3-1.fc23                 @updates                        4.3 M
 gstreamer1-plugins-good                   x86_64 1.6.3-1.fc23                 @updates                        8.5 M
 gupnp-dlna                                x86_64 0.10.3-1.fc23                @@commandline                   353 k
 gvfs-goa                                  x86_64 1.26.2-1.fc23                @updates                        170 k
 libdmapsharing                            x86_64 2.9.30-3.fc23                @@commandline                   330 k
 libgdata                                  x86_64 0.17.4-2.fc23                @updates                        1.7 M
 libgrss                                   x86_64 0.7.0-1.fc23                 @@commandline                   162 k
 libpurple                                 x86_64 2.10.11-16.fc23              @updates                         27 M
 libreoffice-calc                          x86_64 1:5.0.5.2-1.fc23             @updates                         29 M
 libreoffice-core                          x86_64 1:5.0.5.2-1.fc23             @updates                        236 M
 libreoffice-draw                          x86_64 1:5.0.5.2-1.fc23             @updates                        2.2 M
 libreoffice-emailmerge                    x86_64 1:5.0.5.2-1.fc23             @updates                         53 k
 libreoffice-filters                       x86_64 1:5.0.5.2-1.fc23             @updates                          0  
 libreoffice-graphicfilter                 x86_64 1:5.0.5.2-1.fc23             @updates                        1.3 M
 libreoffice-impress                       x86_64 1:5.0.5.2-1.fc23             @updates                        4.8 M
 libreoffice-math                          x86_64 1:5.0.5.2-1.fc23             @updates                        3.5 M
 libreoffice-pdfimport                     x86_64 1:5.0.5.2-1.fc23             @updates                        541 k
 libreoffice-pyuno                         x86_64 1:5.0.5.2-1.fc23             @updates                        1.9 M
 libreoffice-writer                        x86_64 1:5.0.5.2-1.fc23             @updates                         15 M
 libreoffice-writer2latex                  x86_64 1.0.2-17.fc23                @@commandline                   503 k
 libreoffice-xsltfilter                    x86_64 1:5.0.5.2-1.fc23             @updates                        3.6 M
 libzapojit                                x86_64 0.0.3-7.fc23                 @@commandline                   111 k
 megasync                                  x86_64 2.6.1-12.1                   @MEGAsync                       4.9 M
 nautilus                                  x86_64 3.18.5-1.fc23                @updates                         12 M
 nautilus-megasync                         x86_64 2.6.0-1.1                    @MEGAsync                        62 k
 opencv                                    x86_64 2.4.12.3-1.fc23              @updates                         25 M
 openoffice.org-diafilter                  x86_64 1.7.4-1.fc23                 @@commandline                   9.3 M
 pulseaudio-gdm-hooks                      x86_64 7.1-1.fc23                   @updates                        354  
 python3-meh-gui                           noarch 0.43-1.fc23                  @@commandline                    18 k
 rhythmbox                                 x86_64 3.3-2.fc23                   @updates                         15 M
 rygel                                     x86_64 0.28.2-1.fc23                @updates                        3.8 M
 seed                                      x86_64 3.8.1-6.fc23                 @@commandline                   658 k
 shotwell                                  x86_64 0.23.0-0.1.20160105gitf2fb1f7.fc23
                                                                               @updates                         12 M
 sushi                                     x86_64 3.18.0-1.fc23                @@commandline                   311 k
 telepathy-farstream                       x86_64 0.6.1-6.fc23                 @@commandline                   199 k
 telepathy-haze                            x86_64 0.8.0-3.fc22                 @System                         231 k
 totem                                     x86_64 1:3.18.1-1.fc23              @@commandline                   7.4 M
 totem-nautilus                            x86_64 1:3.18.1-1.fc23              @@commandline                    35 k
 tracker                                   x86_64 1.6.1-1.fc23                 @updates                        5.3 M
 tracker-preferences                       x86_64 1.6.1-1.fc23                 @updates                        262 k
 unoconv                                   noarch 0.7-1.fc23                   @@commandline                   240 k
 vinagre                                   x86_64 3.18.2-1.fc23                @updates                        3.0 M
 webkitgtk                                 x86_64 2.4.9-3.fc23                 @@commandline                    44 M
 webkitgtk3                                x86_64 2.4.9-3.fc23                 @@commandline                    44 M
 webkitgtk4                                x86_64 2.10.7-1.fc23                @updates                         81 M
 yelp                                      x86_64 2:3.17.2-3.fc23              @@commandline                   2.2 M
 yelp-libs                                 x86_64 2:3.17.2-3.fc23              @@commandline                   242 k

Transaction Summary
=====================================================================================================================
Remove  96 Packages

Installed size: 838 M
Is this ok [y/N]: n
Operation aborted.



Version-Release number of selected component (if applicable):
libsolv-0.6.14-7.fc23.x86_64
hawkey-0.6.2-3.fc23.x86_64
dnf-1.1.6-2.fc23.noarch

How reproducible: Not sure what is causing it, on two of my systems is reproducible 100%, although slight variation between packages present.


Steps to Reproduce:
1.
2.
3.

Actual results: Uninstalling one harmless package would make system half-unusable.


Expected results: Only few dependencies pulled when removing a package 


Additional info: rpmfusion repo is installed and enabled on both systems, and some of the packages are installed from there.
Comment 1 Jan Kurik 2016-02-24 10:28:56 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Honza Silhan 2016-02-29 07:29:20 EST
possible duplicate of bug 1292915.
Comment 3 Honza Silhan 2016-03-11 04:07:33 EST

*** This bug has been marked as a duplicate of bug 1292915 ***
Comment 4 srakitnican 2016-07-21 15:34:39 EDT
Seems this bug is not duplicate of bug 1292915 after all.


https://bugzilla.redhat.com/show_bug.cgi?id=1292915#c16
Comment 5 srakitnican 2016-07-21 15:48 EDT
Created attachment 1182658 [details]
debugdata

Debugdata with new libsolv version

$ rpm -q libsolv hawkey dnf
libsolv-0.6.22-3.fc25.x86_64
hawkey-0.6.3-2.fc25.x86_64
dnf-1.1.9-2.fc25.noarch
Comment 6 Jan Kurik 2016-07-26 00:53:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 7 Igor Gnatenko 2016-07-27 08:28:49 EDT
I removed [cleandeps], but nothing really changed which means all packages which are going to be removed - have hard dependency on gstreamer stuff.

Note You need to log in before you can comment on or make changes to this bug.