Bug 1310854 - RFE: enable modbus plugin in collectd please?
RFE: enable modbus plugin in collectd please?
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: collectd (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruben Kerkhof
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 14:56 EST by Eric Sandeen
Modified: 2016-04-02 15:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: collectd-5.5.1-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-02 15:25:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2016-02-22 14:56:35 EST
I sent some patches upstream to fix up the modbus collectd plugin and have been using it with success.  Could you please consider enabling it (possibly in EPEL7 as well?)

%package modbus
Summary:       Modbus plugin for collectd
Group:         System Environment/Daemons
Requires:      collectd = %{version}-%{release}
BuildRequires: libmodbus-devel

%description modbus
This plugin connects to a Modbus "slave" via Modbus/TCP or Modbus/RTU
and reads register values.

...

%files modbus
%{_libdir}/collectd/modbus.so


Thanks,
-Eric
Comment 1 Eric Sandeen 2016-02-22 14:59:05 EST
To be clear, those patches made it upstream some time ago, not asking for any additional patches, just enabling the plugin (remove --disable-modbus too of course).

Thanks,
-Eric
Comment 2 Eric Sandeen 2016-02-22 15:05:25 EST
Hm, libmodbus isn't in EPEL7 so that's another small hurdle.  I'll request it.
Comment 3 Ruben Kerkhof 2016-02-23 05:05:38 EST
Hey Eric,

Indeed, I didn't enable it because EPEL7 doesn't have libmodbus.
As soon as it is in, let me know and I'll update collectd.
Comment 4 Eric Sandeen 2016-02-23 10:47:57 EST
Great, thanks, I may own libmodbus in epel7 myself, just sorting that all out.
Apologies if it was already on in fedora and I just forgot to check.  Thanks for straightening me out.  ;)
Comment 5 Ruben Kerkhof 2016-02-24 09:14:04 EST
Heh, no problem. If there's anything I can do to help, let me know.
Love how you are monitoring your boiler with Collectd btw :)
Comment 6 Eric Sandeen 2016-02-26 18:06:21 EST
I'm building libmodbus for epel7 now.

It'd be great to include that modbus debug patch as well, if you think of it :)

Thanks,
-Eric
Comment 7 Ruben Kerkhof 2016-02-27 07:24:00 EST
Sure, will do!
Comment 8 Eric Sandeen 2016-03-14 00:01:03 EDT
I pushed libmodbus to epel7 stable tonight.

Thanks,
Eric
Comment 9 Fedora Update System 2016-03-16 10:23:02 EDT
collectd-5.5.1-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8dbf30da45
Comment 10 Fedora Update System 2016-03-18 18:51:37 EDT
collectd-5.5.1-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8dbf30da45
Comment 11 Fedora Update System 2016-04-02 15:25:22 EDT
collectd-5.5.1-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.