Bug 1310883 - old partition table is not wiped out and create conflict (and grub error is ignored)
Summary: old partition table is not wiped out and create conflict (and grub error is i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Upstream M3
: 10.0 (Newton)
Assignee: Lucas Alvares Gomes
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-22 21:56 UTC by Gonéri Le Bouder
Modified: 2018-02-06 19:41 UTC (History)
11 users (show)

Fixed In Version: openstack-ironic-6.1.1-0.20160823055226.46dc395.el7ost
Doc Type: Bug Fix
Doc Text:
The Bare Metal provisioning service now wipes a disk's metadata before partitioning and writing an image into it. This ensures that the new image boots normally. In previous releases, the Bare Metal provisioning service didn't remove old metadata before starting work on a device, which made it possible for a deployment to fail.
Clone Of:
Environment:
Last Closed: 2016-12-14 15:24:43 UTC


Attachments (Terms of Use)
grub error silently ignored (26.87 KB, image/png)
2016-02-22 21:56 UTC, Gonéri Le Bouder
no flags Details
the two table as seen by fdisk (19.92 KB, image/png)
2016-02-22 21:57 UTC, Gonéri Le Bouder
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 284347 None None None 2016-03-01 19:50:12 UTC
OpenStack gerrit 286283 None None None 2016-03-01 19:50:37 UTC

Description Gonéri Le Bouder 2016-02-22 21:56:42 UTC
Created attachment 1129508 [details]
grub error silently ignored

Description of problem:

Ironic does not clean properly an existing partition table before the deployment and this create a conflict during the new partition creation.

Version-Release number of selected component (if applicable):


How reproducible:

1. Inject an image on the root disk, like ipxe.usb or ipxe.iso
2. Try to deploy a system on the node using Ironic
3. Deployment succeed
4. Node reboots and boot fails

Actual results:

Node should boot after deployment.

Expected results:


Additional info:

Comment 2 Gonéri Le Bouder 2016-02-22 21:57:51 UTC
Created attachment 1129509 [details]
the two table as seen by fdisk

Comment 3 Gonéri Le Bouder 2016-02-22 21:59:06 UTC
http://eavesdrop.openstack.org/irclogs/%23openstack-ironic/%23openstack-ironic.2016-01-06.log.html#t2016-01-06T11:48:03 this has been discussed on IRC in January.

Comment 4 Dmitry Tantsur 2016-02-25 14:11:40 UTC
Hi! Ironic does clean the partition before deploying. Could you please provide ironic-conductor logs to see if something went wrong during this process?

Comment 5 Gonéri Le Bouder 2016-02-25 14:29:35 UTC
This is the message I guess without the patch:
http://paste.openstack.org/show/488191/

If I can sgdisk -Z I still get this one:
http://paste.openstack.org/show/488189/

Comment 6 Dmitry Tantsur 2016-09-06 16:01:29 UTC
I see both patches have merged, moving to MODIFIED.

Comment 10 errata-xmlrpc 2016-12-14 15:24:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.