Bug 1310900 - /usr/@DATADIRNAME@/ is an unusual place for a /locale/ directory.
/usr/@DATADIRNAME@/ is an unusual place for a /locale/ directory.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libsoup (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 18:09 EST by Peter Trenholme
Modified: 2016-02-23 09:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 09:27:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2016-02-22 18:09:23 EST
Description of problem: I just noticed that the message files for libsoup had been installed in the above, fairly unusual, location on 17 Feb. (I assume that this was the result of an error in the .rpm file.)

Version-Release number of selected component (if applicable): 2.53.90-1

How reproducible: Didn't try

Steps to Reproduce: n/a

Actual results: See above

Expected results: Files installed in /usr/share/locale/../LC_MESSAGES/libsoup.mo, where /../ is the locale code.

Additional info I noticed this when I did a ls on /usr, and marked it "low" priority because - as far as I know - I don't often use libsoup, but if the library pops an error, and doesn't look for its messages the the "strange" location, will they see a error message that's hard to understand?

I did look in /usr/share/locale/, and no libsoup.mo files are there, so the cleanup after the rpm was installed probably removed them.
Comment 1 Dan Winship 2016-02-23 09:27:49 EST
Yeah, this is caused by an old bug in intltool, which has always been fixed in f23, but for some reason I needed to do an "intltoolize --force" to overwrite the old buggy version of po/Makefile.in.in. Anyway, it will be fixed in the .91 tarball.

Note You need to log in before you can comment on or make changes to this bug.