Bug 1310906 - Provide warning when adding role to nonexistent group/user
Provide warning when adding role to nonexistent group/user
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jordan Liggitt
weiwei jiang
: UpcomingRelease
: 1339507 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 18:27 EST by Eric Jones
Modified: 2016-05-31 09:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
OpenShift Enterprise 3.1
Last Closed: 2016-04-28 12:05:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Jones 2016-02-22 18:27:14 EST
- What is the nature and description of the request? 
As an user, if I know that a group (or user) exists, and have permissions to see the groups/users, but make a typo when adding a role to the group/user I should receive a warning that the group/user does not exist, potentially receive the option to create it anyway, but I should at least receive the warning.

- Why does the customer need this? (List the business requirements here) 
End users will be able to add users/groups to their project in any number of roles, however typos do occur and this warning will save the system admin's a lot of trouble caused by mistakes

- How would the customer like to achieve this? (List the functional requirements here) 
Something along the lines of checking if a user has permission to do something, just create a warning if they have permission to but are giving a role to a nonexistent group/user

- For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
Attempt to add role to group that doesn't exist

- Is there already an existing RFE upstream or in Red Hat Bugzilla?
Not that I could find.
Comment 10 Jordan Liggitt 2016-05-31 09:52:06 EDT
*** Bug 1339507 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.