Bug 1310913 - sqlite update blocks
sqlite update blocks
Status: CLOSED DUPLICATE of bug 1310441
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Staněk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 19:11 EST by Przemek Klosowski
Modified: 2016-02-23 09:44 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 09:44:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Przemek Klosowski 2016-02-22 19:11:44 EST
Description of problem:
sqlite cannot be upgraded from 3.10.2 to 3.11.0

Version-Release number of selected component (if applicable):
sqlite-3.11.0-1.fc23.x86_64 and sqlite-3.10.2-1.fc23.x86_64

How reproducible: every time


Steps to Reproduce:
1. dnf update -y --best

Actual results:
Last metadata expiration check performed 1:56:53 ago on Mon Feb 22 17:04:14 2016.
Error: cannot install both sqlite-3.11.0-1.fc23.x86_64 and sqlite-3.10.2-1.fc23.x86_64


Expected results: successful update
Comment 1 Przemek Klosowski 2016-02-22 19:14:30 EST
I am not sure what dependencies prevent this upgrade. I checked the requires for both packages, and clearly there was a change in the method they were specified:

dnf repoquery --requires sqlite-3.11.0-1.fc23.x86_64  
Last metadata expiration check performed 0:00:00 ago on Mon Feb 22 19:02:19 2016.
libc.so.6(GLIBC_2.14)(64bit)
libdl.so.2()(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libncurses.so.5()(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libreadline.so.6()(64bit)
libtinfo.so.5()(64bit)
rtld(GNU_HASH)
sqlite-libs = 3.11.0-1.fc23

dnf repoquery --requires sqlite-3.10.2-1.fc23.x86_64
Last metadata expiration check performed 0:00:19 ago on Mon Feb 22 19:02:19 2016.
libc.so.6()(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libdl.so.2()(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libncurses.so.5()(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libreadline.so.6()(64bit)
libsqlite3.so.0()(64bit)
libtinfo.so.5()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
Comment 2 Felix Schwarz 2016-02-23 08:34:14 EST
Maybe this is because of bug 1310441? Can you check if you have the i686 version of sqlite installed?
Comment 3 Nils Philippsen 2016-02-23 09:44:47 EST
To me it looks like it:

- sqlite.i686 would lock sqlite.x86_64 to the same version on multi-lib
- both old and new versions can't be installed at the same time

I'll just assume it's a duplicate of the mentioned bug, feel free to poke me if I'm wrong.

*** This bug has been marked as a duplicate of bug 1310441 ***

Note You need to log in before you can comment on or make changes to this bug.