Bug 1310958 - OSP8 overcloud deployment hang
OSP8 overcloud deployment hang
Status: CLOSED DUPLICATE of bug 1310956
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: James Slagle
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 21:31 EST by Kaihua Chen
Modified: 2016-05-12 18:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 21:33:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaihua Chen 2016-02-22 21:31:53 EST
Description of problem:
When trying to deploy the overcloud with basic configuration (1 controller and 1 compute). the deployment process is hang.

Version-Release number of selected component (if applicable):
Latest OSP8 release.

How reproducible:
Always!

Steps to Reproduce:
1. install the undercloud
2. edit the deployment templates
3. run openstack deploy command (openstack overcloud deploy).

Actual results:
[stack@director ~]$ ./deploy.sh
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
ERROR: Authentication failed. Please try again with option --include-password or export HEAT_INCLUDE_PASSWORD=1
Authentication required

[stack@director ~]$ cat deploy.sh
openstack overcloud deploy --templates -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /home/stack/templates/network-environment.yaml --control-flavor control --compute-flavor compute --neutron-public-interface ens9f0 --ntp-server 10.254.67.22 --neutron-network-type gre --neutron-tunnel-types gre

[stack@director ~]$ heat resource-list overcloud |grep -i pro
| Compute                                   | 28f50806-afc2-4403-96e0-d10f222f46dc          | OS::Heat::ResourceGroup                           | CREATE_IN_PROGRESS | 2016-02-22T02:16:49 |
| Controller                                | 4692dce3-22f4-4797-8108-ee7e320e2b01          | OS::Heat::ResourceGroup                           | CREATE_IN_PROGRESS | 2016-02-22T02:16:49 |


Expected results:
Overcloud deployment is successful.

Additional info:
As you see, the deployment is still in progress, but we have see some authentication error.

And also it says that we need a parameter like --include-password, but from the openstack overcloud deploy help, there isn't such parameter.

I know to investigate this issue, you need more logs and files to check, I am glad to provide any requested files.
Comment 2 Kaihua Chen 2016-02-22 21:33:40 EST

*** This bug has been marked as a duplicate of bug 1310956 ***

Note You need to log in before you can comment on or make changes to this bug.