Bug 1311005 - rabbitmq-cluster resource instance may not be able to rejoin the rabbitmq cluster.
rabbitmq-cluster resource instance may not be able to rejoin the rabbitmq clu...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
All All
urgent Severity urgent
: ---
: 8.0 (Liberty)
Assigned To: Jiri Stransky
Leonid Natapov
:
Depends On:
Blocks: 1311025
  Show dependency treegraph
 
Reported: 2016-02-23 02:41 EST by Michele Baldessari
Modified: 2016-04-07 17:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.10-1.el7ost
Doc Type: Bug Fix
Doc Text:
The notify=true parameter was previously missing from the RabbitMQ Pacemaker resource. Consequently, RabbitMQ instances were unable to rejoin the RabbitMQ cluster. This update adds support for notify=true to the pacemaker resource agent for RabbitMQ, and adds notify=true to OpenStack director. As a result, RabbitMQ instances are now able to rejoin the RabbitMQ cluster.
Story Points: ---
Clone Of:
: 1311025 (view as bug list)
Environment:
Last Closed: 2016-04-07 17:48:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 283461 None None None 2016-02-23 04:24 EST

  None (edit)
Description Michele Baldessari 2016-02-23 02:41:59 EST
Description of problem:
Sometimes when a controller is rebooted the node is unable to join the rabbitmq
cluster. This issue needs the following to happen to be fixed:

1) BZ https://bugzilla.redhat.com/show_bug.cgi?id=1247303 needs a fix in the resource agent (see this BZ for more history about this issue)

2) We need to add the meta parameter "notify=true" on fresh installs and on updates.


Note, that if the fix to THT makes it in before the fix of the resource agent,
nothing happens (i.e. things keep going like before)
Comment 5 Leonid Natapov 2016-03-16 08:24:27 EDT
openstack-tripleo-heat-templates-0.8.10-2.el7ost

[root@overcloud-controller-0 heat-admin]# pcs resource show rabbitmq
 Resource: rabbitmq (class=ocf provider=heartbeat type=rabbitmq-cluster)
  Attributes: set_policy="ha-all ^(?!amq\.).* {"ha-mode":"all"}" 
  Meta Attrs: notify=true 
  Operations: start interval=0s timeout=100 (rabbitmq-start-interval-0s)
              stop interval=0s timeout=90 (rabbitmq-stop-interval-0s)
              monitor interval=10 timeout=40 (rabbitmq-monitor-interval-10)
[root@overcloud-controller-0 heat-admin]#
Comment 7 errata-xmlrpc 2016-04-07 17:48:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.