Bug 1311032 - Sqlite 3.11 breaks Thunderbird
Sqlite 3.11 breaks Thunderbird
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 1310864 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 03:35 EST by Remi Collet
Modified: 2016-03-10 09:53 EST (History)
11 users (show)

See Also:
Fixed In Version: 38.6.0-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-26 09:24:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2016-02-23 03:35:57 EST
Description of problem:
Since sqlite 3.11.0, "chat" doesn't work anymore (twitter, jabber, irc)

The left panel (with connected contact and channel) is empty, despite account are reported as connected

Version-Release number of selected component (if applicable):
thunderbird-38.6.0-1.fc23.x86_64
sqlite-3.11.0-1.fc23.x86_64


How reproducible:
Always

Steps to Reproduce:
1. yum update
2. use the "Chat" feature
3.

Actual results:
Nothing in the left panel

Expected results:
Connected contacts and channels

Additional info:
Downgrading to sqlite 3.10 solves this (no easy because of the split)
Comment 1 marianne@tuxette.fr 2016-02-23 04:09:27 EST
I have thunderbid-conversations extension and the research tool broken

sqlite-3.11.0-1.fc23.x86_64
thunderbird-38.6.0-1.fc23.x86_64
Comment 2 Remi Collet 2016-02-23 04:11:52 EST
Notice: a simple rebuild of F23 .src.rpm against sqlite 3.11 doesn"t solves the issue.
Comment 3 Nick Cross 2016-02-23 04:32:39 EST
I am seeing this as well with F23, latest Thunderbird and Converdations installed. Conversations then does not appear to work. I have tried with another user and clean profile to no avail. A binary from mozilla.org works fine. Symptoms and error messages match https://bugs.archlinux.org/task/48260

I think its also related to bug 1310864
Comment 4 Remi Collet 2016-02-23 04:59:25 EST
Add sqlite maintainer in CC.
Comment 5 Martin Stransky 2016-02-23 06:04:47 EST
New builds (thunderbird-38.6.0-3) which should address this are in koji now.
Comment 6 Remi Collet 2016-02-23 07:02:46 EST
I confirm 38.6.0-3.fc23 works
Comment 7 Miro Hrončok 2016-02-24 06:45:57 EST
I confirm 38.6.0-3.fc23 works (Conversations)
Comment 8 marianne@tuxette.fr 2016-02-24 07:12:53 EST
Works with 38.6.0-3.fc23
Comment 9 Martin Stransky 2016-02-24 10:12:56 EST
There's the update: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d50cdefcef
Comment 10 Martin Stransky 2016-02-26 09:24:17 EST
Bodhi doesn't allow me to add this bug to the update so closing by hand.
Comment 11 Martin Stransky 2016-02-26 09:25:05 EST
*** Bug 1310864 has been marked as a duplicate of this bug. ***
Comment 12 Wayne Mery (:wsmwk) 2016-03-08 18:04:48 EST
https://bugzilla.mozilla.org/show_bug.cgi?id=1254510
Comment 13 udo 2016-03-10 09:53:02 EST
Anything beyond thunderbird 38.6.0-1 crashes on startup.
The sqlite change is suspect.
sqlite-3.10.2-1.fc22.x86_64 is here.

Note You need to log in before you can comment on or make changes to this bug.