Bug 1311080 - [RFE] Add firewall support in gdeploy configuration
[RFE] Add firewall support in gdeploy configuration
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: RHGS 3.1.3
Assigned To: Nandaja Varma
SATHEESARAN
: FutureFeature, ZStream
Depends On:
Blocks: Gluster-HC-1 1311386
  Show dependency treegraph
 
Reported: 2016-02-23 05:57 EST by Sachidananda Urs
Modified: 2016-07-03 21:12 EDT (History)
7 users (show)

See Also:
Fixed In Version: gdeploy-2.0-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:29:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2016-02-23 05:57:14 EST
Add firewall support in gdeploy configuration.

User should be able run firewall-cmd on remote nodes.
Comment 3 SATHEESARAN 2016-05-11 05:15:27 EDT
Tested with gdeploy-2.0-11

There is a 'firewalld' section available to add a firewalld service, open a port, delete a firewalld service, delete a opened port

[firewalld]
action=add
zone=public
permanent=yes
service=glusterfs,rpc-bind
ports=5667/tcp

The above conf file helps in the addition firewalld services - glusterfs, rpc-bind. Also opens the port 5667/tcp for traffic permanently

[firewalld]
action=delete
service=glusterfs

The above conf file removes the firewalld service 'glusterfs'
Comment 5 errata-xmlrpc 2016-06-23 01:29:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1250

Note You need to log in before you can comment on or make changes to this bug.