Bug 1311100 - [abrt] abrt-addon-vmcore: abrt-harvest-vmcore:104:write_to_file:IOError: [Errno 2] No such file or directory: '/var/tmp/abrt/vmcore-127.0.0.1-2013.09.07-13:42:25.new/uuid'
[abrt] abrt-addon-vmcore: abrt-harvest-vmcore:104:write_to_file:IOError: [Err...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: abrt (Show other bugs)
7.3
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: abrt
Martin Kyral
https://retrace.fedoraproject.org/faf...
abrt_hash:b8db45fa3c93a48e41a431b7c8e...
: EasyFix, Patch
Depends On: 1077241
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 06:56 EST by Jakub Filak
Modified: 2016-11-03 23:09 EDT (History)
11 users (show)

See Also:
Fixed In Version: abrt-2.1.11-36.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1077241
Environment:
Last Closed: 2016-11-03 23:09:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (1.43 KB, patch)
2016-04-18 11:20 EDT, Matej Habrnal
no flags Details | Diff

  None (edit)
Description Jakub Filak 2016-02-23 06:56:00 EST
+++ This bug was initially created as a clone of Bug #1077241 +++

Version-Release number of selected component:
abrt-addon-vmcore-2.1.12-2.fc20

Additional info:
reporter:       libreport-2.1.12
cmdline:        /usr/bin/python /usr/sbin/abrt-harvest-vmcore
executable:     /usr/sbin/abrt-harvest-vmcore
kernel:         3.13.3-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
abrt-harvest-vmcore:104:write_to_file:IOError: [Errno 2] No such file or directory: '/var/tmp/abrt/vmcore-127.0.0.1-2013.09.07-13:42:25.new/uuid'

Traceback (most recent call last):
  File "/usr/sbin/abrt-harvest-vmcore", line 290, in <module>
    harvest_vmcore()
  File "/usr/sbin/abrt-harvest-vmcore", line 276, in harvest_vmcore
    create_abrtd_info(destdirnew)
  File "/usr/sbin/abrt-harvest-vmcore", line 164, in create_abrtd_info
    write_to_file(os.path.join(dest, 'uuid'), hashobj.hexdigest())
  File "/usr/sbin/abrt-harvest-vmcore", line 104, in write_to_file
    with open(path, 'w') as wfile:
IOError: [Errno 2] No such file or directory: '/var/tmp/abrt/vmcore-127.0.0.1-2013.09.07-13:42:25.new/uuid'

Local variables in innermost frame:
content: '9e3b539426b2a0bc19e54f67ec033240d75a4eee'
path: '/var/tmp/abrt/vmcore-127.0.0.1-2013.09.07-13:42:25.new/uuid'

--- Additional comment from Milan Bouchet-Valat on 2014-03-17 15:56:10 CET ---



--- Additional comment from Milan Bouchet-Valat on 2014-03-17 15:56:13 CET ---



--- Additional comment from Milan Bouchet-Valat on 2014-08-10 19:42:23 CEST ---

Seen once again with up-to-date F20. This is annoying since I cannot report kernel crashes using abrt-vmcore.

--- Additional comment from Jakub Filak on 2014-11-27 12:52:37 CET ---

Thank you for the report! I opened a pull request for this bug report:
https://github.com/abrt/abrt/pull/883

--- Additional comment from Milan Bouchet-Valat on 2014-11-27 14:09:41 CET ---

Thanks! But does that fix the problem, or just the handling of the error, i.e. does that mean that reporting kernel crashed will work?

--- Additional comment from Jakub Filak on 2014-11-27 15:05:38 CET ---

(In reply to Milan Bouchet-Valat from comment #5)
> Thanks! But does that fix the problem, or just the handling of the error,
> i.e. does that mean that reporting kernel crashed will work?

Yes, the patch only makes sure that the service will remain working if something removed the destination problem directory (I can't imagine how is that possible, perhaps something remounted /var or a temporary data cleaner did that). In such a case, the service will skip the currently processed vmcore and will continue with the next one.

I verified that the processing of vmcores works as expected under normal circumstances.

--- Additional comment from Milan Bouchet-Valat on 2014-11-27 15:26:15 CET ---

OK, I'll see whether harvesting vmcores now works on F21.

--- Additional comment from Fedora Update System on 2015-02-16 14:56:04 CET ---

abrt-2.2.2-2.fc20,libreport-2.2.3-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/abrt-2.2.2-2.fc20,libreport-2.2.3-3.fc20

--- Additional comment from Fedora Update System on 2015-02-17 09:10:10 CET ---

Package abrt-2.2.2-2.fc20, libreport-2.2.3-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.2.2-2.fc20 libreport-2.2.3-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2191/abrt-2.2.2-2.fc20,libreport-2.2.3-3.fc20
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2015-04-28 14:59:22 CEST ---

abrt-2.2.2-2.fc20, libreport-2.2.3-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 2 Matej Habrnal 2016-04-18 11:20 EDT
Created attachment 1148235 [details]
Patch
Comment 6 errata-xmlrpc 2016-11-03 23:09:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2307.html

Note You need to log in before you can comment on or make changes to this bug.