Bug 1311125 - vpx_codec_enc_init_multi_ver is not present on aarch64
vpx_codec_enc_init_multi_ver is not present on aarch64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvpx (Show other bugs)
rawhide
aarch64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARM64/F-ExcludeArch-aarch64 1310753
  Show dependency treegraph
 
Reported: 2016-02-23 07:54 EST by Marcin Juszkiewicz
Modified: 2016-03-26 14:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: libvpx-1.5.0-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:03:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results of libvpx build (logs, rpms, srpm) (4.91 MB, application/x-xz)
2016-03-09 01:51 EST, Marcin Juszkiewicz
no flags Details

  None (edit)
Description Marcin Juszkiewicz 2016-02-23 07:54:48 EST
Description of problem:

qt5-qtwebengine is using libvpx as build dependency. But on AArch64 build fails due to lack of vpx_codec_enc_init_multi_ver() in libvpx.so ;(

Version-Release number of selected component (if applicable):

1.5.0-2

How reproducible:

always

Steps to Reproduce:
1. do build of qt5-qtwebengine (arm-koji is enough for scratch builds)
2.
3.

Actual results:

/builddir/build/BUILD/qtwebengine-opensource-src-5.6.0-beta/aarch64-redhat-linux-gnu/src/core/Release/obj/src/3rdparty/chromium/third_party/webrtc/modules/video_coding/codecs/vp8/libwebrtc_vp8.a(/builddir/build/BUILD/qtwebengine-opensource-src-5.6.0-beta/aarch64-redhat-linux-gnu/src/core/Release/obj/src/3rdparty/chromium/third_party/webrtc/modules/video_coding/codecs/vp8/webrtc_vp8.vp8_impl.o):vp8_impl.cc:function webrtc::VP8EncoderImpl::InitAndSetControlSettings(): error: undefined reference to 'vpx_codec_enc_init_multi_ver'

Expected results:

qt5-qtwebengine package builds

Additional info:
Comment 1 Tom "spot" Callaway 2016-02-23 15:49:18 EST
I don't have aarch64 hardware, and I can't even download the libvpx build you're referencing:

http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=348638

Best guess is that because aarch64 isn't natively supported, the generic-gnu target that it is using is not fully featured enough.

If you can give me shell access to an aarch64 system (preferably with sudo so I can install BuildRequires), I might be able to fix this.
Comment 2 Marcin Juszkiewicz 2016-02-24 01:14:24 EST
Tom: Beaker has some aarch64 machines available.
Comment 3 Marcin Juszkiewicz 2016-03-08 08:34:58 EST
If I unset generic_target for 'generic-gnu' builds then vpx_codec_enc_init_multi_ver() is available on aarch64/ppc64 (not checked s390).

And then: 

Wrote: /builddir/build/RPMS/qt5-qtwebengine-5.6.0-0.19.rc.fc24.aarch64.rpm
Comment 4 Tom "spot" Callaway 2016-03-08 20:47:08 EST
Can you give me the full build logs from the aarch64 build with generic-gnu unset. I'm not sure that libvpx knows how to build for aarch64, but if qt5-qtwebengine linked against it... i'm wondering if it detected as armv7 and just worked with the %{optflags}. Just need to know how to conditionalize it in the spec.
Comment 5 Marcin Juszkiewicz 2016-03-09 01:51 EST
Created attachment 1134395 [details]
results of libvpx build (logs, rpms, srpm)

This is whole results directory including build logs, resulting rpms and source rpm used.
Comment 6 Tom "spot" Callaway 2016-03-16 11:00:09 EDT
Aha, okay, I see what is going on now. I'll get that fixed in a moment.
Comment 7 Tom "spot" Callaway 2016-03-16 11:34:02 EDT
libvpx-1.5.0-4.fc24 & libvpx-1.5.0-4.fc25 are now built.
Comment 8 Fedora Update System 2016-03-16 12:52:45 EDT
libvpx-1.5.0-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aeeccd648d
Comment 9 Fedora Update System 2016-03-18 10:57:49 EDT
libvpx-1.5.0-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aeeccd648d
Comment 10 Marcin Juszkiewicz 2016-03-21 04:28:58 EDT
qt5-qtwebengine got built ;)

http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=362634
Comment 11 Fedora Update System 2016-03-26 14:03:22 EDT
libvpx-1.5.0-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.