Bug 1311153 - Address feedback on Chapter 2
Address feedback on Chapter 2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
Unspecified
Unspecified Unspecified
medium Severity medium (vote)
: Beta
: 6.2
Assigned To: Allison Heslin
Brandi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 09:02 EST by Andrew Dahms
Modified: 2016-04-27 19:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-27 19:58:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Dahms 2016-02-23 09:02:50 EST
The following items must be addressed in Chapter 2. of the Installation Guide:

* In Section 2.1, is there a way that users can determine the required number 
  of inodes?

* In Section 2.1, state that symbolic links cannot be used for /var/lib/mongdob 
  and /var/lib/pulp

* In Section 2.1, change the description of avoiding NFS similar to the 
  following -

  "Red Hat recommends the usage of high-bandwidth, low-latency storage for the 
  /var/lib/pulp & /var/lib/mongodb filesystems. As Red Hat Satellite has many 
  operations that are IO intensive, usage of high latency, low-bandwidth 
  storage could potentially have issues with performance degradation. 
  Additionally, usage of NFS backed storage may require additional
  configuration."

* In Section 2.3., change "A current Red Hat Network subscription" to "A 
  current Red Hat Satellite subscription"

* In "2.4. Ports and Firewalls requirements", add a note that the ports 
  required depends on the configuration.

* Remove table 2.3.

* Change "Third-party unsupported and enabled yum repositories, which can cause 
  installation or configuration errors." to "Additional yum repositories other 
  than those explicitly required in this guide for installation."

* In Table 2.4, ports 53, 67, 68 & 69 are ALL optional and should be moved to 
  table 2.5. They are not required features.

* In Section 2.5, remove Step 2.

* In Section 2.5, change "subscription-manager subscribe" to "subscription-
  manager --attach"

* In Section 2.5, change "--pool=Red_Hat_Enterprise_Linux_Pool_ID" to 
  "--pool=Red_Hat_Satellite_Pool_ID"

* In Section 2.6, is it possible to add examples of the output when a command
  is successfully run?

* In Section 2.7, remove mention of 'zones' from the title and text, and add
  steps on setting the current server time before installing ntpd.

* In Section 2.8, SELinux can be running in permission OR enforced. Also, add
  a little clarification that these steps are only required if the user is
  using non-standard ports.

* In Section 2.11 and 2.13, add clarification as to whether these steps are 
  optional or required - are they only required if the user is also isntalling
  a Capsule Server? Also, can the steps be more clearly broken into those
  for RHEL 6 and for RHEL 7?

* Make sections 2.10 to 2.13 sub-sections of section 2.4.
Comment 1 Andrew Dahms 2016-02-23 09:03:10 EST
Assigning to Ali for review.
Comment 2 Allison Heslin 2016-02-25 11:11:33 EST
* In Section 2.1, state that symbolic links cannot be used for /var/lib/mongdob 
  and /var/lib/pulp
[Ali] Done

* In Section 2.1, change the description of avoiding NFS similar to the 
  following -

  "Red Hat recommends the usage of high-bandwidth, low-latency storage for the 
  /var/lib/pulp & /var/lib/mongodb filesystems. As Red Hat Satellite has many 
  operations that are IO intensive, usage of high latency, low-bandwidth 
  storage could potentially have issues with performance degradation. 
  Additionally, usage of NFS backed storage may require additional
  configuration."
[Ali] Done

* In Section 2.2., change "A current Red Hat Network subscription" to "A 
  current Red Hat Satellite subscription"
[Ali] Done

* In "2.4. Ports and Firewalls requirements", add a note that the ports 
  required depends on the configuration.
[Ali] Done

* Remove table 2.3.
[Ali] Done

* Change "Third-party unsupported and enabled yum repositories, which can cause 
  installation or configuration errors." to "Additional yum repositories other 
  than those explicitly required in this guide for installation."
[Ali] Done

* In Table 2.4, ports 53, 67, 68 & 69 are ALL optional and should be moved to 
  table 2.5. They are not required features.
[Ali] Done

* In Section 2.5, remove Step 2.
[Ali] Done

* In Section 2.5, change "subscription-manager subscribe" to "subscription-
  manager --attach"
[Ali] Done

* In Section 2.5, change "--pool=Red_Hat_Enterprise_Linux_Pool_ID" to 
  "--pool=Red_Hat_Satellite_Pool_ID"
[Ali] Done

* In Section 2.8, SELinux can be running in permission OR enforced. Also, add
  a little clarification that these steps are only required if the user is
  using non-standard ports.
[Ali] Done

* Make sections 2.10 to 2.13 sub-sections of section 2.4.
[Ali] Done I relocated these underneath 2.4, but not as sub-sections as it's not necessary.
Comment 3 Allison Heslin 2016-03-02 13:47:04 EST
* In Section 2.6, is it possible to add examples of the output when a command
  is successfully run?
[Ali] DONE

* 2.5. Registering and Configuring Subscription Manager for use with Satellite
“After you have installed your operating system, you must register and configure Subscription Manager to ensure that you have the latest versions of Red Hat Enterprise Linux during Satellite installation.” I’m not entirely sure of this wording, but happy to discuss.
[Ali] DONE


“ 1. Register and attach a subscription to your system.”
These commands look simple enough but in practice they’re not. The RHEV docs (IIRC) provide a great example of how to find the right pool ID. We should emulate their instructions.
[Ali] DONE Updated based on RHEV documentation and the Provisioning Guide/QS Guide
Comment 4 Allison Heslin 2016-03-07 14:23:10 EST
* In Section 2.7, remove mention of 'zones' from the title and text, and add
  steps on setting the current server time before installing ntpd.
[Ali] Done

* Section 2.2

The wording of 'Red Hat supports. Red Hat Satellite is only supported on the latest version of Red Hat Enterprise
Linux 6 Server or 7 Server.' is ambiguous and is borderline on being untrue. What we are saying is 'the latest version of RHEL that was current when we released (or better) is supported. 
[Ali] DONE - Also added the table with the minimum RHEL versions.

* In the Notes: Section, is it true that Satellites & capsules must match. (I know from 6.0 to 6.1 this was a no, due to the Isolated Capsule feature), but is that true for 6.1->6.2
[Ali] DONE - no change required since they must still match.

* 2.1. Storage Requirements and Recommendations
“Alternatively, make sure that you have an ext4 file system with sufficient amount of inodes for your intended Satellite deployment.” With what information can a customer determine the “sufficient amount of inodes”?

"Alternatively, make sure that you have an ext4 file system with sufficient amount of
inodes for your intended Satellite deployment."

What defines sufficient? As a user I need to know whether to use 'mkfs -t ext4 -T' or 'mkfs -t ext4 -N'
[Ali] Dropped sentence starting with Alternatively, per mmccune (bz1244130 solved issue)
Comment 5 Andrew Dahms 2016-04-27 19:58:11 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.